summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrainBlasted2018-04-16 01:27:27 -0400
committerBrainBlasted2018-04-16 01:27:27 -0400
commit683da7044f1f18de46b0c350079bb65893264dbd (patch)
tree75d1bc1711e3796785b5329327eebe16ff77125e
downloadaur-683da7044f1f18de46b0c350079bb65893264dbd.tar.gz
Initial commit
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD31
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2dc7c23c0579
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = hammond-git
+ pkgdesc = A Podcast Client for the GNOME Desktop written in Rust (Git version)
+ pkgver = r950.0589f2f
+ pkgrel = 1
+ url = https://gitlab.gnome.org/World/hammond
+ arch = x86_64
+ license = GPL3
+ makedepends = gtk3
+ makedepends = rust
+ makedepends = pkg-config
+ makedepends = git
+ makedepends = meson
+ makedepends = git
+ depends = glib2
+ depends = openssl
+ depends = sqlite
+ depends = gtk3
+ provides = hammond
+ conflicts = hammond
+ source = git+https://gitlab.gnome.org/World/hammond.git
+ sha256sums = SKIP
+
+pkgname = hammond-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9c5b091c6e4c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: brainblasted <brainblasted at disroot dot org>
+pkgname=hammond-git
+pkgver=r950.0589f2f
+pkgrel=1
+_gitname=hammond
+pkgdesc="A Podcast Client for the GNOME Desktop written in Rust (Git version)"
+arch=('x86_64')
+license=('GPL3')
+provides=('hammond')
+conflicts=('hammond')
+url="https://gitlab.gnome.org/World/hammond"
+depends=('glib2' 'openssl' 'sqlite' 'gtk3')
+makedepends=('gtk3' 'rust' 'pkg-config' 'git' 'meson' 'git')
+source=("git+https://gitlab.gnome.org/World/hammond.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}"/"${_gitname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${srcdir}"/"${_gitname}"
+ meson . _build --prefix=/usr
+ ninja -C _build
+}
+
+package() {
+ cd "${srcdir}"/"${_gitname}"
+ DESTDIR="$pkgdir" ninja -C _build install
+}