summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornot_anonymous2023-08-25 18:50:31 -0600
committernot_anonymous2023-08-25 18:50:31 -0600
commita4eff3229888b6d6919cbd8c76d54829d6fe53c5 (patch)
treef733a44f4c267227c35cb840b15c10ce9c76b765
downloadaur-a4eff3229888b6d6919cbd8c76d54829d6fe53c5.tar.gz
New-submission
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD38
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bb99f8d40d29
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = hamrs-appimage
+ pkgdesc = Ham Radio portable logger tailored for activities like Parks on the Air, Field Day, and others.
+ pkgver = 1.0.6
+ pkgrel = 1
+ url = https://hamrs.app/
+ arch = x86_64
+ license = custom:electron
+ depends = fuse2
+ depends = hicolor-icon-theme
+ depends = hamradio-menus
+ provides = hamrs
+ conflicts = hamrs
+ options = !strip
+ source = https://hamrs-releases.s3.us-east-2.amazonaws.com/1.0.6/hamrs-1.0.6-linux-x86_64.AppImage
+ md5sums = 8ffeb9c5ba99158c94e409c5c5f383d2
+ sha256sums = d234be158780c36cdc4f284bc2aaf775e406e2fde7bd9245d613f60a3b5a1795
+
+pkgname = hamrs-appimage
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b64438099077
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: not_anonymous <nmlibertarian@gmail.com>
+# Contributor: Sean Snell <ssnell@lakecs.net>
+# Submission: not_anonymous <nmlibertarian@gmail.com>
+
+pkgname=hamrs-appimage
+_pkgname=hamrs
+_install_path="/opt/appimages"
+pkgver=1.0.6
+pkgrel=1
+pkgdesc="Ham Radio portable logger tailored for activities like Parks on the Air, Field Day, and others."
+arch=('x86_64')
+url="https://hamrs.app/"
+license=('custom:electron')
+depends=('fuse2' 'hicolor-icon-theme' 'hamradio-menus')
+provides=('hamrs')
+conflicts=('hamrs')
+options=(!strip)
+source=("https://$_pkgname-releases.s3.us-east-2.amazonaws.com/$pkgver/$_pkgname-$pkgver-linux-$arch.AppImage")
+
+prepare() {
+ chmod a+x "$_pkgname-$pkgver-linux-$arch.AppImage"
+ "./$_pkgname-$pkgver-linux-$arch.AppImage" --appimage-extract > /dev/null
+ sed 's|AppRun|/opt/appimages/hamrs.AppImage|g;s|Utilities|Utility;HamRadio|g' -i "$srcdir/squashfs-root/$_pkgname.desktop"
+}
+
+package() {
+ install -Dm755 "$srcdir/$_pkgname-$pkgver-linux-$arch.AppImage" "$pkgdir/$_install_path/$_pkgname.AppImage"
+ install -Dm644 "$srcdir/squashfs-root/$_pkgname.desktop" "$pkgdir/usr/share/applications/$_pkgname.desktop"
+
+ for _icons in 16x16 24x24 32x32 48x48 64x64 128x128 256x256 512x512 1024x1024;do
+ install -Dm644 "$srcdir/squashfs-root/usr/share/icons/hicolor/$_icons/apps/$_pkgname.png" \
+ "$pkgdir/usr/share/icons/hicolor/$_icons/apps/$_pkgname.png"
+ done
+
+ install -Dm644 "$srcdir/squashfs-root/LICENSE.electron.txt" -t "$pkgdir/usr/share/licenses/$pkgname"
+}
+md5sums=('8ffeb9c5ba99158c94e409c5c5f383d2')
+sha256sums=('d234be158780c36cdc4f284bc2aaf775e406e2fde7bd9245d613f60a3b5a1795')