summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F. Rødseth2019-03-27 10:18:16 +0100
committerAlexander F. Rødseth2019-03-27 10:18:16 +0100
commit05f48989720911ee2a87555dababde73a61f98e0 (patch)
treefb73a81280631b7014e1bf3f46696d7e04bd8d30
downloadaur-05f48989720911ee2a87555dababde73a61f98e0.tar.gz
Move from [community] to AUR in connection with the spring cleaning
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD43
2 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6227a9f42b45
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by mksrcinfo v8
+# Wed Mar 27 09:15:59 UTC 2019
+pkgbase = hamster-time-tracker
+ pkgdesc = Time tracking application that helps you to keep track on how much time you have spent during the day on activities you choose to track
+ pkgver = 1.04
+ pkgrel = 4
+ url = https://github.com/projecthamster/hamster
+ arch = any
+ license = GPL
+ makedepends = intltool
+ makedepends = gnome-doc-utils
+ depends = python2-dbus
+ depends = python2-gconf
+ depends = python2-notify
+ depends = python2-wnck
+ depends = python2-xdg
+ depends = desktop-file-utils
+ source = https://github.com/projecthamster/hamster/archive/hamster-time-tracker-1.04.tar.gz
+ md5sums = 148ffee0c26c5c4ddfa4ebc9a21fa860
+
+pkgname = hamster-time-tracker
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..732a8d7053f8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer:
+# Contributor: Balló György <ballogyor+arch at gmail dot com>
+# Contributor: Jan de Groot <jgc@archlinux.org>
+# Contributor: Georg Vogetseder <georg.vogetseder@gmail.com>
+
+pkgname=hamster-time-tracker
+pkgver=1.04
+pkgrel=4
+pkgdesc="Time tracking application that helps you to keep track on how much time you have spent during the day on activities you choose to track"
+arch=('any')
+url="https://github.com/projecthamster/hamster"
+license=('GPL')
+depends=('python2-dbus' 'python2-gconf' 'python2-notify' 'python2-wnck' 'python2-xdg' 'desktop-file-utils')
+makedepends=('intltool' 'gnome-doc-utils')
+source=(https://github.com/projecthamster/hamster/archive/$pkgname-$pkgver.tar.gz)
+md5sums=('148ffee0c26c5c4ddfa4ebc9a21fa860')
+
+prepare() {
+ cd hamster-$pkgname-$pkgver
+
+ # Python2 fix
+ find . -type f | xargs sed -i 's@^#!.*python$@#!/usr/bin/python2@'
+
+ # Fix version number
+ sed -i '/VERSION/ s/1.03.3/1.04/' wscript
+}
+
+build() {
+ cd hamster-$pkgname-$pkgver
+ python2 ./waf configure --prefix=/usr
+ python2 ./waf build
+}
+
+package() {
+ cd hamster-$pkgname-$pkgver
+ python2 ./waf install --destdir=$pkgdir
+
+ # Move bash completion and GConf schema to its correct place
+ install -dm755 "$pkgdir/usr/share/bash-completion/completions"
+ mv "$pkgdir/etc/bash_completion.d/hamster.bash" "$pkgdir/usr/share/bash-completion/completions/hamster"
+ mv "$pkgdir/etc/gconf" "$pkgdir/usr/share"
+ rm -r "$pkgdir/etc"
+}