summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSanskritFritz2020-03-10 21:10:37 +0100
committerSanskritFritz2020-03-10 21:10:37 +0100
commitb919826e9caa936f5c99260abf45de01823bc1ea (patch)
treeae6ce1c9605f35e6b983493a6ffd5d553ef330c1
downloadaur-b919826e9caa936f5c99260abf45de01823bc1ea.tar.gz
Upstream version 1.04
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD44
2 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7a7e7a28ec86
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = hamster-time-tracker_legacy
+ pkgdesc = Time tracking application that helps you to keep track on how much time you have spent during the day on activities you choose to track (Legacy 1.04 version)
+ pkgver = 1.04
+ pkgrel = 1
+ url = https://github.com/projecthamster/hamster
+ arch = any
+ license = GPL
+ makedepends = intltool
+ makedepends = gnome-doc-utils
+ depends = python2-dbus
+ depends = python2-gconf
+ depends = python2-notify
+ depends = python2-wnck
+ depends = python2-xdg
+ depends = desktop-file-utils
+ source = https://github.com/projecthamster/hamster/archive/hamster-time-tracker-1.04.tar.gz
+ md5sums = 148ffee0c26c5c4ddfa4ebc9a21fa860
+
+pkgname = hamster-time-tracker_legacy
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..60a2baeab921
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: SanskritFritz (gmail)
+# Contributor: Balló György <ballogyor+arch at gmail dot com>
+# Contributor: Jan de Groot <jgc@archlinux.org>
+# Contributor: Georg Vogetseder <georg.vogetseder@gmail.com>
+
+pkgname=hamster-time-tracker_legacy
+_pkgname=hamster-time-tracker
+pkgver=1.04
+pkgrel=1
+pkgdesc="Time tracking application that helps you to keep track on how much time you have spent during the day on activities you choose to track (Legacy 1.04 version)"
+arch=('any')
+url="https://github.com/projecthamster/hamster"
+license=('GPL')
+depends=('python2-dbus' 'python2-gconf' 'python2-notify' 'python2-wnck' 'python2-xdg' 'desktop-file-utils')
+makedepends=('intltool' 'gnome-doc-utils')
+source=(https://github.com/projecthamster/hamster/archive/$_pkgname-$pkgver.tar.gz)
+md5sums=('148ffee0c26c5c4ddfa4ebc9a21fa860')
+
+prepare() {
+ cd hamster-$_pkgname-$pkgver
+
+ # Python2 fix
+ find . -type f | xargs sed -i 's@^#!.*python$@#!/usr/bin/python2@'
+
+ # Fix version number
+ sed -i '/VERSION/ s/1.03.3/1.04/' wscript
+}
+
+build() {
+ cd hamster-$_pkgname-$pkgver
+ python2 ./waf configure --prefix=/usr
+ python2 ./waf build
+}
+
+package() {
+ cd hamster-$_pkgname-$pkgver
+ python2 ./waf install --destdir=$pkgdir
+
+ # Move bash completion and GConf schema to its correct place
+ install -dm755 "$pkgdir/usr/share/bash-completion/completions"
+ mv "$pkgdir/etc/bash_completion.d/hamster.bash" "$pkgdir/usr/share/bash-completion/completions/hamster"
+ mv "$pkgdir/etc/gconf" "$pkgdir/usr/share"
+ rm -r "$pkgdir/etc"
+}