summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAstroFloyd2018-03-31 11:02:03 +0200
committerAstroFloyd2018-03-31 11:02:03 +0200
commitf37d02112a91f0217345e79ed1816b5293da9899 (patch)
tree66119bc21b42b64450faf71c966e83a4c98f3899
downloadaur-f37d02112a91f0217345e79ed1816b5293da9899.tar.gz
Version bump to v0.2
-rw-r--r--.SRCINFO19
-rw-r--r--ChangeLog15
-rw-r--r--PKGBUILD21
3 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a80eb6391c44
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Sat Mar 31 08:56:27 UTC 2018
+pkgbase = han-ese-ops-arch-rpi
+ pkgdesc = Scripts for the Raspberry Pi for the Final Assignment of HAN ESE OPS
+ pkgver = 0.2
+ pkgrel = 1
+ url = https://github.com/MarcvdSluys/han-ese-ops-arch-rpi
+ changelog = ChangeLog
+ arch = any
+ license = GPL3
+ depends = bash
+ depends = python3
+ depends = python-sense-hat
+ depends = python-netifaces
+ source = https://github.com/MarcvdSluys/han-ese-ops-arch-rpi/archive/han-ese-ops-arch-rpi-0.2.tar.gz
+ sha512sums = 8e39a6d2c6a5c59eafc16f3dcc618d47bafa81e2cafcf668091e7424104791f234a2b4bcf947cfc38c90d00514f1e735380a1ebbf8c7346d7f0e280df58c5585
+
+pkgname = han-ese-ops-arch-rpi
+
diff --git a/ChangeLog b/ChangeLog
new file mode 100644
index 000000000000..8cb5e0824886
--- /dev/null
+++ b/ChangeLog
@@ -0,0 +1,15 @@
+ChangeLog for han-ese-ops-arch-rpi PKGBUILD
+https://github.com/MarcvdSluys/han-ese-ops-arch-rpi
+
+ * han-ese-ops-arch-rpi-0.2-1 (2018-03-31 - MvdS)
+ Version bump
+
+ * han-ese-ops-arch-rpi-0.1-3 (2017-12-25 - MvdS)
+ Add dependency python-netifaces
+
+ * han-ese-ops-arch-rpi-0.1-2 (2017-12-21 - MvdS)
+ Add dependency python-sense-hat
+
+ * han-ese-ops-arch-rpi-0.1-1 (2017-12-18 - MvdS)
+ Initial PKGBUILD for han-ese-ops-arch-rpi, to be uploaded to AUR
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..95fa73d423a7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Marc van der Sluys < git [at] vandersluys [dt] nl >
+pkgname=han-ese-ops-arch-rpi
+pkgver=0.2
+pkgrel=1
+pkgdesc="Scripts for the Raspberry Pi for the Final Assignment of HAN ESE OPS"
+arch=('any')
+url="https://github.com/MarcvdSluys/han-ese-ops-arch-rpi"
+license=('GPL3')
+depends=('bash' 'python3' 'python-sense-hat' 'python-netifaces')
+changelog=ChangeLog
+source=("https://github.com/MarcvdSluys/han-ese-ops-arch-rpi/archive/han-ese-ops-arch-rpi-${pkgver}.tar.gz")
+sha512sums=('8e39a6d2c6a5c59eafc16f3dcc618d47bafa81e2cafcf668091e7424104791f234a2b4bcf947cfc38c90d00514f1e735380a1ebbf8c7346d7f0e280df58c5585')
+
+package() {
+ cd han-ese-ops-arch-rpi-han-ese-ops-arch-rpi-${pkgver}
+ mkdir -p ${pkgdir}/usr/bin/ ${pkgdir}/usr/lib/systemd/system/
+ cp -vp python/* ${pkgdir}/usr/bin/
+ cp -vp shell/* ${pkgdir}/usr/bin/
+ cp -vp systemd/* ${pkgdir}/usr/lib/systemd/system/
+ chmod a+x ${pkgdir}/usr/bin/*
+}