summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorClaudia2024-03-04 00:12:22 +0100
committerClaudia2024-03-04 00:12:22 +0100
commit785a9b0e2addf274bd9b55a3a28b3abc6cebcc90 (patch)
tree88189da2d4c2c7155461b256a8e7c126c7b1d5d6
downloadaur-785a9b0e2addf274bd9b55a3a28b3abc6cebcc90.tar.gz
hancho v0.0.1
-rw-r--r--.SRCINFO17
-rw-r--r--.editorconfig20
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD59
4 files changed, 103 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ce2bc0c4e3bf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = hancho
+ pkgdesc = Simple pleasant build system in Python
+ pkgver = 0.0.1
+ pkgrel = 1
+ url = https://github.com/aappleby/hancho
+ arch = any
+ license = MIT
+ checkdepends = gtk3
+ depends = python
+ optdepends = gtk3: to build the included meson example
+ options = !strip
+ source = hancho-0.0.1.tar.gz::https://github.com/aappleby/hancho/archive/0.0.1.tar.gz
+ source = https://raw.githubusercontent.com/aappleby/hancho/81c57cde7d09dfed0731f2506d2a6bb296515e5d/LICENSE
+ sha512sums = 36600d832d7a2726282b679cc89ac026c7e5c415919505e6adce4f7eba574eccab7105ddc09d05c655449ab6e0f92e78a85284f30d38b1685678bf7f6c7ff5ff
+ sha512sums = c5048ded873a9c0b8a2a50bbbde763ecb6c8b32883ac793382570435080a150ef78e56238c7141aaf8f465cadaf1023cd19d1275d9df834e6aaf815081edc6d1
+
+pkgname = hancho
diff --git a/.editorconfig b/.editorconfig
new file mode 100644
index 000000000000..29215c86a3df
--- /dev/null
+++ b/.editorconfig
@@ -0,0 +1,20 @@
+# https://editorconfig.org
+
+root = true
+
+[*]
+charset = utf-8
+end_of_line = lf
+indent_style = space
+insert_final_newline = true
+trim_trailing_whitespace = true
+
+[*.{diff,patch}]
+end_of_line = lf
+trim_trailing_whitespace = false
+
+[PKGBUILD]
+indent_size = 2
+
+[*.json]
+indent_size = 2
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e30280919486
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+/.vscode/
+/src
+/pkg
+/LICENSE
+*.log
+*.pkg.*
+*.tar.*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..194b7d8318a7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,59 @@
+# Maintainer: Claudia Pellegrino <aur ät cpellegrino.de>
+
+pkgname=hancho
+pkgver=0.0.1
+pkgrel=1
+pkgdesc='Simple pleasant build system in Python'
+arch=('any')
+url='https://github.com/aappleby/hancho'
+license=('MIT')
+depends=('python')
+checkdepends=('gtk3')
+optdepends=(
+ 'gtk3: to build the included meson example'
+)
+options=('!strip')
+
+source=(
+ "${pkgname}-${pkgver}.tar.gz::https://github.com/aappleby/hancho/archive/${pkgver}.tar.gz"
+ 'https://raw.githubusercontent.com/aappleby/hancho/81c57cde7d09dfed0731f2506d2a6bb296515e5d/LICENSE'
+)
+
+sha512sums=(
+ '36600d832d7a2726282b679cc89ac026c7e5c415919505e6adce4f7eba574eccab7105ddc09d05c655449ab6e0f92e78a85284f30d38b1685678bf7f6c7ff5ff'
+ 'c5048ded873a9c0b8a2a50bbbde763ecb6c8b32883ac793382570435080a150ef78e56238c7141aaf8f465cadaf1023cd19d1275d9df834e6aaf815081edc6d1'
+)
+
+prepare() {
+ find "${srcdir}/${pkgname}-${pkgver}" -name .gitignore \
+ -exec rm -v '{}' +
+}
+
+check() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ CHECK_WD="$(pwd)"
+ # shellcheck disable=SC2317
+ hancho() { python "${CHECK_WD}/hancho.py"; }
+ export CHECK_WD
+ export -f hancho
+ python ./hancho.py
+ rm -rf examples/*/build
+ rm -rf tutorial/build
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ echo >&2 'Packaging the executable'
+ install -D -m 755 -T 'hancho.py' "${pkgdir}/usr/bin/hancho"
+
+ echo >&2 'Packaging the license'
+ install -D -m 644 -t "${pkgdir}/usr/share/licenses/${pkgname}" '../LICENSE'
+
+ echo >&2 'Packaging the documentation'
+ install -D -m 644 -t "${pkgdir}/usr/share/doc/${pkgname}" 'README.md'
+ cp -vR 'docs' 'tutorial' "${pkgdir}/usr/share/doc/${pkgname}/"
+
+ echo >&2 'Packaging the examples'
+ mkdir -pv "${pkgdir}/usr/share/${pkgname}"
+ cp -vR 'examples' "${pkgdir}/usr/share/${pkgname}/"
+}