summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGalen Guyer2022-07-12 23:38:39 -0400
committerGalen Guyer2022-07-12 23:38:39 -0400
commitabc89cad85f377bb8b8eb8600e762c1613935921 (patch)
tree53291bde174938bf2d5c13af7ab31208d00930e1
parenta20c73e9bb506baf5ec43371250b427bdf19d473 (diff)
downloadaur-abc89cad85f377bb8b8eb8600e762c1613935921.tar.gz
Update to use new Rust git repository
-rw-r--r--PKGBUILD16
1 files changed, 5 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 46208c60f455..390e02967b56 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Galen Guyer <galen@galenguyer.com>
pkgname='hancock-git'
_gitname=hancock
-pkgver=2022.02.02_40
+pkgver=2022.07.12_13
pkgrel=1
description='A simple x509 certificate manager (git version)'
arch=('any')
url='https://github.com/galenguyer/hancock'
license=('MIT')
-makedepends=('git' 'go')
-source=('git+https://github.com/galenguyer/hancock-go')
+makedepends=('git' 'rust')
+source=('git+https://github.com/galenguyer/hancock')
sha256sums=('SKIP')
pkgver() {
@@ -18,18 +18,12 @@ pkgver() {
printf "%s_%s\n" "${_date}" "${_commits}" | sed 's/-/./g'
}
-
-prepare() {
- cd "$_gitname"
- mkdir -p build/
-}
-
build () {
cd "$_gitname"
- go build -o build/
+ cargo build --release
}
package () {
cd "$_gitname"
- install -Dm755 build/$_gitname "$pkgdir"/usr/bin/$_gitname
+ install -Dm755 "target/release/$_gitname" "$pkgdir/usr/bin/$_gitname"
}