summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames Bunton2016-12-28 12:30:16 +1100
committerJames Bunton2016-12-28 12:30:51 +1100
commitd0abebb1e02b64cca2dad5986b059806e0b4b91d (patch)
tree0caa24ff23924c190c2a810f6c2116aa8f737a06
parentb286f9964a4df3a1ebe749932acc01090ec9ee49 (diff)
downloadaur-d0abebb1e02b64cca2dad5986b059806e0b4b91d.tar.gz
Update to 1.0.0
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD46
-rw-r--r--handbrake-fix-missing-x265-link-flag.patch13
3 files changed, 53 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ddce9b0d7df8..4cc10bc12d59 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sun May 1 01:13:43 UTC 2016
+# Wed Dec 28 01:30:41 UTC 2016
pkgbase = handbrake-fdkaac
- pkgver = 0.10.5
- pkgrel = 2
+ pkgver = 1.0.0
+ pkgrel = 1
url = https://handbrake.fr/
arch = i686
arch = x86_64
@@ -28,15 +28,20 @@ pkgbase = handbrake-fdkaac
makedepends = cmake
makedepends = libtheora
makedepends = libsamplerate
- makedepends = libbluray
+ makedepends = ffmpeg
makedepends = x264
makedepends = libx264
+ makedepends = x265
+ makedepends = libvpx
makedepends = libdvdnav
+ makedepends = jansson
makedepends = librsvg
makedepends = libgudev
makedepends = libfdk-aac
- source = https://handbrake.fr/mirror/HandBrake-0.10.5.tar.bz2
- sha256sums = fb9230dd121b456f6829d1d25ac8bbf76e503b51c4efc70f0a7fd2bb8607e2f0
+ source = https://handbrake.fr/mirror/HandBrake-1.0.0.tar.bz2
+ source = handbrake-fix-missing-x265-link-flag.patch
+ sha256sums = 15fb4593c70d75621212e4499f018c3c93d7ce39f1083bf527d4616ded0044c5
+ sha256sums = 05e212e76b6e0b94a04de02cbeb7bf9db607059e19297b5bd3d0d143135285c4
pkgname = handbrake-fdkaac
pkgdesc = Multithreaded video transcoder
@@ -56,15 +61,17 @@ pkgname = handbrake-fdkaac
depends = libvorbis
depends = libtheora
depends = libsamplerate
- depends = libbluray
+ depends = ffmpeg
depends = libx264
+ depends = x265
+ depends = libvpx
depends = libdvdnav
+ depends = jansson
depends = librsvg
depends = libgudev
depends = desktop-file-utils
depends = hicolor-icon-theme
depends = libfdk-aac
- depends = libx264.so
optdepends = gst-plugins-good: for video previews
optdepends = gst-libav: for video previews
conflicts = handbrake
@@ -80,10 +87,12 @@ pkgname = handbrake-cli-fdkaac
depends = libxml2
depends = libtheora
depends = libsamplerate
- depends = libbluray
+ depends = ffmpeg
depends = libx264
+ depends = x265
+ depends = libvpx
depends = libdvdnav
+ depends = jansson
depends = libfdk-aac
- depends = libx264.so
conflicts = handbrake-cli
diff --git a/PKGBUILD b/PKGBUILD
index 24aafd6750eb..d67215cbe72c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,44 +4,42 @@
# Contributor: Sebastien Piccand <sebcactus gmail com>
pkgname=('handbrake-fdkaac' 'handbrake-cli-fdkaac')
-pkgver=0.10.5
-pkgrel=2
+pkgver=1.0.0
+pkgrel=1
arch=('i686' 'x86_64')
url="https://handbrake.fr/"
license=('GPL')
makedepends=('intltool' 'python2' 'yasm' 'wget' 'bzip2' 'gcc-libs' 'libnotify'
'gst-plugins-base' 'gtk3' 'dbus-glib' 'fribidi' 'libass' 'lame'
'fontconfig' 'freetype2' 'libxml2' 'libogg' 'libvorbis' 'cmake'
- 'libtheora' 'libsamplerate' 'libbluray' 'x264' 'libx264'
- 'libdvdnav' 'librsvg' 'libgudev' 'libfdk-aac')
-source=(https://handbrake.fr/mirror/HandBrake-$pkgver.tar.bz2)
-sha256sums=('fb9230dd121b456f6829d1d25ac8bbf76e503b51c4efc70f0a7fd2bb8607e2f0')
+ 'libtheora' 'libsamplerate' 'ffmpeg' 'x264' 'libx264' 'x265'
+ 'libvpx' 'libdvdnav' 'jansson' 'librsvg' 'libgudev' 'libfdk-aac')
+source=(https://handbrake.fr/mirror/HandBrake-$pkgver.tar.bz2
+ handbrake-fix-missing-x265-link-flag.patch)
+sha256sums=('15fb4593c70d75621212e4499f018c3c93d7ce39f1083bf527d4616ded0044c5'
+ '05e212e76b6e0b94a04de02cbeb7bf9db607059e19297b5bd3d0d143135285c4')
prepare() {
cd "$srcdir/HandBrake-$pkgver"
+ # https://bugs.gentoo.org/show_bug.cgi?id=552792
+ patch -Np1 -i ../handbrake-fix-missing-x265-link-flag.patch
+
# Use more system libs
- # We had ffmpeg here as well but it broke PGS subtitle processing
- # https://forum.handbrake.fr/viewtopic.php?f=13&t=27581
- sed -i \
- -e '/MODULES += contrib\/libbluray/d' \
- -e '/MODULES += contrib\/libdvdnav/d' \
- -e '/MODULES += contrib\/libdvdread/d' \
- make/include/main.defs
+ # Bundled libbluray is kept because it is patched locally
+ for _lib in ffmpeg x265 libvpx libdvdnav libdvdread; do
+ sed -i "/MODULES += contrib\/$_lib/d" make/include/main.defs
+ done
}
build() {
cd "$srcdir/HandBrake-$pkgver"
- export CXXFLAGS="${CXXFLAGS} -std=gnu++98"
- export CPPFLAGS="${CPPFLAGS} -std=gnu++98"
./configure \
--prefix=/usr \
- --force \
--disable-gtk-update-checks \
--enable-fdk
- cd build
- make
+ make -C build
}
package_handbrake-fdkaac() {
@@ -49,10 +47,9 @@ package_handbrake-fdkaac() {
conflicts=('handbrake')
depends=('bzip2' 'gcc-libs' 'gst-plugins-base' 'libnotify' 'dbus-glib'
'fribidi' 'libass' 'lame' 'gtk3' 'fontconfig' 'freetype2' 'libxml2'
- 'libogg' 'libvorbis' 'libtheora' 'libsamplerate' 'libbluray'
- 'libx264' 'libdvdnav' 'librsvg' 'libgudev' 'desktop-file-utils'
- 'hicolor-icon-theme' 'libfdk-aac')
- depends+=('libx264.so')
+ 'libogg' 'libvorbis' 'libtheora' 'libsamplerate' 'ffmpeg' 'libx264'
+ 'x265' 'libvpx' 'libdvdnav' 'jansson' 'librsvg' 'libgudev'
+ 'desktop-file-utils' 'hicolor-icon-theme' 'libfdk-aac')
optdepends=('gst-plugins-good: for video previews'
'gst-libav: for video previews')
@@ -66,9 +63,8 @@ package_handbrake-cli-fdkaac() {
pkgdesc="Multithreaded video transcoder (CLI)"
conflicts=('handbrake-cli')
depends=('bzip2' 'gcc-libs' 'zlib' 'fribidi' 'libass' 'lame' 'libxml2'
- 'libtheora' 'libsamplerate' 'libbluray' 'libx264' 'libdvdnav'
- 'libfdk-aac')
- depends+=('libx264.so')
+ 'libtheora' 'libsamplerate' 'ffmpeg' 'libx264' 'x265' 'libvpx'
+ 'libdvdnav' 'jansson' 'libfdk-aac')
cd "$srcdir/HandBrake-$pkgver/build"
install -D HandBrakeCLI "$pkgdir/usr/bin/HandBrakeCLI"
diff --git a/handbrake-fix-missing-x265-link-flag.patch b/handbrake-fix-missing-x265-link-flag.patch
new file mode 100644
index 000000000000..a963fe0af216
--- /dev/null
+++ b/handbrake-fix-missing-x265-link-flag.patch
@@ -0,0 +1,13 @@
+Written by: Peter Foley <pefoley2@pefoley.com>
+Gentoo Bug: #552792
+
+--- a/test/module.defs
++++ b/test/module.defs
+@@ -25,6 +25,7 @@
+
+ ifeq (1,$(FEATURE.x265))
+ TEST.GCC.D += USE_X265
++ TEST.GCC.l += x265
+ endif
+
+ TEST.GCC.l += $(foreach m,$(MODULES.NAMES),$($m.OSL.libs))