summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGavin Costello2015-08-25 07:59:02 +0200
committerGavin Costello2015-08-25 07:59:02 +0200
commite144f7881b8175c6e4ff9059e229d5435a4b22ad (patch)
tree30bb8c1ef85330098ade0a335f0fe87a43a2781c
parent35e9128e103208bdb7caed88031e1b48e8ee9af0 (diff)
downloadaur-e144f7881b8175c6e4ff9059e229d5435a4b22ad.tar.gz
Updated to version 3.0.3
-rw-r--r--PKGBUILD19
1 files changed, 7 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c51e19f3775d..3dd4107c9d05 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,22 @@
# Maintainer: Gavin Costello <gavcos at gmail dot com>
# Contributor:
pkgname=handlebars
-pkgver=1.0.0
-pkgrel=8
+pkgver=v3.0.3
+pkgrel=1
pkgdesc="Handlebars.js is an extension to the Mustache templating language created by Chris Wanstrath. Handlebars.js and Mustache are both logicless templating languages that keep the view and the code separated like we all know they should be."
arch=(any)
url="http://handlebarsjs.com"
license=('MIT')
depends=('nodejs')
optdepends=('nodejs-optimist')
-source=("https://raw.github.com/wycats/${pkgname}.js/${pkgver}/dist/${pkgname}.js" "https://raw.github.com/wycats/${pkgname}.js/${pkgver}/bin/${pkgname}" "https://raw.github.com/wycats/${pkgname}.js/${pkgver}/LICENSE")
-md5sums=('6f95155fd6469590d96c9651ee156795'
- '30978ded6d8d63531dd6fa7bd99e0c03'
- 'a2163f3c5de1e75a2210655d3448d598')
+source=("http://builds.handlebarsjs.com.s3.amazonaws.com/${pckname}-${pkgver}.js", "http://builds.handlebarsjs.com.s3.amazonaws.com/${pckname}.runtime-${pkgver}.js"
+md5sums=('26161aef7f4d10f0c21adc7c183c0c1b'
+ '7ae2ab0c40c56dca97c1add08d32561e')
package() {
cd "${srcdir}"
-# mkdir -p "${pkgdir}/usr/share/${pkgname}"
-# mkdir -p "${pkgdir}/usr/bin"
-# mkdir -p "${pkgdir}/usr/share/licenses/${pkgname}"
- install -Dm644 "${pkgname}.js" "${pkgdir}/usr/share/${pkgname}"
- install -Dm755 "${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
- install -Dm755 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm755 "${pkgname}-${pkgver}.js" "${pkgdir}/usr/bin/${pkgname}.js"
+ install -Dm755 "${pkgname}.runtime-${pkgver}.js" "${pkgdir}/usr/bin/${pkgname}.runtime.js"
}
# vim:set ts=2 sw=2 et: