summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsemeion2018-12-08 00:49:37 -0200
committersemeion2018-12-08 00:49:37 -0200
commitab7e3739779cee8c0f4d277eccbf66467b8643ef (patch)
tree1b4927743484eb86b417c80dcfcee556b144e60a
parent526a2046bfbcf99a37357bd7a106b0cd2de1bf4d (diff)
downloadaur-ab7e3739779cee8c0f4d277eccbf66467b8643ef.tar.gz
added GPU support 2018.12.08. 00:49:37
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
2 files changed, 5 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aec18f3f23b2..a6740ef7e653 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,6 +7,8 @@ pkgbase = handshake-cracker
license = GPL3
makedepends = git
depends = aircrack-ng
+ depends = hcxtools
+ depends = hashcat
depends = wireshark-cli
depends = cowpatty
depends = mdk3
diff --git a/PKGBUILD b/PKGBUILD
index d21c4c81ffe7..e777bfdfd32b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,8 +8,9 @@ pkgdesc="Handshake capture with aircrack-ng, test with pyrit, crack with john th
arch=('any')
url='https://github.com/semeion/handshake-cracker'
license=('GPL3')
-depends=('aircrack-ng' 'wireshark-cli' 'cowpatty' 'mdk3' 'xterm' 'ncurses' 'psmisc' 'gawk' 'macchanger'
- 'coreutils' 'glibc' 'sed' 'gzip' 'bzip2' 'unzip' 'wget' 'sudo' 'less' 'john' 'python2' 'python2-lxml')
+depends=('aircrack-ng' 'hcxtools' 'hashcat' 'wireshark-cli' 'cowpatty' 'mdk3' 'xterm' 'ncurses' 'psmisc' 'gawk'
+ 'macchanger' 'coreutils' 'glibc' 'sed' 'gzip' 'bzip2' 'unzip' 'wget' 'sudo' 'less' 'john' 'python2' 'python2-lxml')
+#optdepends=('hcxdumptool')
makedepends=('git')
source=('git+https://github.com/semeion/handshake-cracker.git')
sha256sums=('SKIP') # use 'updpkgsums' if you want
@@ -22,14 +23,12 @@ pkgver() {
package()
{
cd "${srcdir}/${pkgname}"
-
# Install script
install -D -m755 crack "${pkgdir}/usr/bin/crack"
install -D -m755 crawler-dicionarioinformal "${pkgdir}/usr/bin/crawler-dicionarioinformal"
install -D -m755 crawler-dictionary "${pkgdir}/usr/bin/crawler-dictionary"
install -D -m755 handshake "${pkgdir}/usr/bin/handshake"
install -D -m755 wordlist "${pkgdir}/usr/bin/wordlist"
-
# Install john config with custom rules
install -D -m644 john.conf.custom "${pkgdir}/etc/john/john.conf.custom"
}