summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYG2019-10-09 16:45:15 -0400
committerYG2019-10-09 16:45:15 -0400
commit23682492e092c84a983fbb020d1acf2ae8699a37 (patch)
treed80349460338b0ab488216dbdfd3c67f21b734b5
downloadaur-23682492e092c84a983fbb020d1acf2ae8699a37.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD31
-rw-r--r--handyoutliner.desktop26
3 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e80f7e461252
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = handyoutliner-bin
+ pkgdesc = The goal of this program is to make easier and faster the process of creating bookmarks for DjVu and PDF documents.
+ pkgver = 1.1.6.3
+ pkgrel = 1
+ url = http://handyoutlinerfo.sourceforge.net/
+ arch = x86_64
+ license = GPL
+ depends = djvulibre
+ depends = mono
+ source = https://prdownloads.sourceforge.net/sourceforge/handyoutlinerfo/handyoutliner_1.1.6.3.zip
+ source = handyoutliner.desktop
+ md5sums = 51a3b3411103564b762605d8bcb17be4
+ md5sums = 55f5c8fa377de829f10632a2d518d06d
+
+pkgname = handyoutliner-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..235bfad760c0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Yadav Gowda <yadav . gowda __at__ gmail . com>
+_pkgname=handyoutliner
+pkgname=${_pkgname}-bin
+pkgver=1.1.6.3
+pkgrel=1
+pkgdesc="The goal of this program is to make easier and faster the process of creating bookmarks for DjVu and PDF documents."
+arch=('x86_64')
+url="http://handyoutlinerfo.sourceforge.net/"
+license=('GPL')
+depends=('djvulibre' 'mono')
+source=('https://prdownloads.sourceforge.net/sourceforge/handyoutlinerfo/handyoutliner_1.1.6.3.zip'
+ 'handyoutliner.desktop')
+md5sums=('51a3b3411103564b762605d8bcb17be4'
+ '55f5c8fa377de829f10632a2d518d06d')
+
+prepare() {
+ cd ${_pkgname}_${pkgver}
+ sed -i 's:\$(dirname \$0):/usr/lib/handyoutliner:' start-linux
+ chmod +x start-linux
+ rm start-macos
+}
+
+package() {
+ mkdir -p "$pkgdir/usr/bin"
+ mkdir -p "$pkgdir/usr/lib/handyoutliner"
+ mkdir -p "$pkgdir/usr/share/applications"
+ cp "${srcdir}/handyoutliner.desktop" "${pkgdir}/usr/share/applications/handyoutliner.desktop"
+ cd ${srcdir}/${_pkgname}_${pkgver}
+ cp -R * "${pkgdir}/usr/lib/handyoutliner"
+ ln -s /usr/lib/handyoutliner/start-linux $pkgdir/usr/bin/handyoutliner
+}
diff --git a/handyoutliner.desktop b/handyoutliner.desktop
new file mode 100644
index 000000000000..463da0b02a60
--- /dev/null
+++ b/handyoutliner.desktop
@@ -0,0 +1,26 @@
+[Desktop Entry]
+
+# The type as listed above
+Type=Application
+
+# The version of the desktop entry specification to which this file complies
+Version=1.1.6.3
+
+# The name of the application
+Name=HandyOutliner
+
+# A comment which can/will be used as a tooltip
+Comment=Create PDF/DjVu bookmarks
+
+# The path to the folder in which the executable is run
+Path=/usr/bin/
+
+# The executable of the application, possibly with arguments.
+Exec=handyoutliner
+
+# The name of the icon that will be used to display this entry
+#Icon=handyoutliner
+
+# Describes whether this application needs to be run in a terminal or not
+Terminal=false
+