summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel M. Capella2018-03-05 12:46:24 -0500
committerDaniel M. Capella2018-03-05 12:51:43 -0500
commit253755a3985a76df75b981f33e5978882a5305c7 (patch)
tree6e029aba11fa4bc1da1fb74d7f1ecc9bb1f930df
parent63e4ed2a84e3a2caef3b993e1c156375cd0438ef (diff)
downloadaur-253755a3985a76df75b981f33e5978882a5305c7.tar.gz
Add license and remove check
Tests not included in PyPI sources.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
2 files changed, 8 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7338df3b3cdc..9d84a0bbd8d1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Mon Mar 5 05:45:33 UTC 2018
+# Mon Mar 5 17:48:13 UTC 2018
pkgbase = hangups
pkgdesc = The first third-party instant messaging client for Google Hangouts
pkgver = 0.4.4
@@ -7,8 +7,6 @@ pkgbase = hangups
url = https://github.com/tdryer/hangups
arch = any
license = MIT
- checkdepends = python-httpretty
- checkdepends = python-pytest
depends = python-aiohttp
depends = python-appdirs
depends = python-configargparse
@@ -19,7 +17,9 @@ pkgbase = hangups
depends = python-requests
depends = python-urwid
source = https://files.pythonhosted.org/packages/source/h/hangups/hangups-0.4.4.tar.gz
+ source = hangups-0.4.4.license::https://raw.githubusercontent.com/tdryer/hangups/v0.4.4/LICENSE
sha512sums = d89050e9c7374785be07e88013b98c893cd091ccf93f72c0da787f6390378bccf88058622f683a8a73ae611bc828119c6267cf947963ed8f0277165879823f69
+ sha512sums = 6a0e0c135e55f027e3817ce181c7f5d73a3fd6f4c1ebe6bb28ab61352eeecdf1acdea78178ae6fe1eae8632d99e16e85c973e403644b7eac77c62dfc6c21eae9
pkgname = hangups
diff --git a/PKGBUILD b/PKGBUILD
index 87791a72038a..24248e546db7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,9 +11,10 @@ license=('MIT')
depends=('python-aiohttp' 'python-appdirs' 'python-configargparse'
'python-mechanicalsoup' 'python-protobuf' 'python-readlike'
'python-reparser' 'python-requests' 'python-urwid')
-checkdepends=('python-httpretty' 'python-pytest')
-source=("https://files.pythonhosted.org/packages/source/h/hangups/hangups-$pkgver.tar.gz")
-sha512sums=('d89050e9c7374785be07e88013b98c893cd091ccf93f72c0da787f6390378bccf88058622f683a8a73ae611bc828119c6267cf947963ed8f0277165879823f69')
+source=("https://files.pythonhosted.org/packages/source/h/hangups/hangups-$pkgver.tar.gz"
+ "hangups-$pkgver.license::https://raw.githubusercontent.com/tdryer/hangups/v$pkgver/LICENSE")
+sha512sums=('d89050e9c7374785be07e88013b98c893cd091ccf93f72c0da787f6390378bccf88058622f683a8a73ae611bc828119c6267cf947963ed8f0277165879823f69'
+ '6a0e0c135e55f027e3817ce181c7f5d73a3fd6f4c1ebe6bb28ab61352eeecdf1acdea78178ae6fe1eae8632d99e16e85c973e403644b7eac77c62dfc6c21eae9')
prepare() {
cd hangups-$pkgver
@@ -26,14 +27,10 @@ build() {
python setup.py build
}
-check() {
- cd hangups-$pkgver
- pytest hangups
-}
-
package() {
cd hangups-$pkgver
python setup.py install --prefix=/usr --root="$pkgdir" --optimize=1 --skip-build
+ install -Dm644 ../hangups-$pkgver.license "$pkgdir"/usr/share/licenses/hangups/LICENSE
}
# vim:set ts=2 sw=2 et: