summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoréclairevoyant2023-06-03 19:14:09 -0400
committeréclairevoyant2023-06-03 19:14:09 -0400
commitf87afc5897698bf4aec5e338f00c780781f663c3 (patch)
treebab1cfbbee4ab1a7517583ddd10089cb358d13ed
downloadaur-f87afc5897698bf4aec5e338f00c780781f663c3.tar.gz
happyx-git: init
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD44
3 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1517a9af8e4b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = happyx-git
+ pkgdesc = Macro-oriented asynchronous full-stack web-framework, written in Nim
+ pkgver = 1.0.0.r2.7c01d93
+ pkgrel = 1
+ url = https://github.com/HapticX/happyx
+ arch = x86_64
+ license = GPL3
+ makedepends = choosenim
+ makedepends = git
+ depends = glibc
+ provides = happyx
+ conflicts = happyx
+ source = git+https://github.com/HapticX/happyx.git
+ b2sums = SKIP
+
+pkgname = happyx-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..713f6f80aff8
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/*
+!/.gitignore
+!/.SRCINFO
+!/PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a0df8715eed6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: éclairevoyant
+
+_pkgname=happyx
+pkgname="$_pkgname-git"
+pkgver=1.0.0.r2.7c01d93
+pkgrel=1
+pkgdesc="Macro-oriented asynchronous full-stack web-framework, written in Nim"
+arch=(x86_64)
+url="https://github.com/HapticX/$_pkgname"
+license=(GPL3)
+depends=(glibc)
+makedepends=(choosenim git)
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("git+$url.git")
+b2sums=('SKIP')
+
+_setup() {
+ _nimble_dir="$srcdir/nimbleDir"
+ _path="$_nimble_dir/bin:$PATH"
+ cd $_pkgname
+}
+
+prepare() {
+ _setup
+
+ CHOOSENIM_NO_ANALYTICS=1 choosenim stable --nimbleDir="$_nimble_dir"
+ PATH="$_path" nimble refresh -l
+ PATH="$_path" nimble install -d -l
+}
+
+pkgver() {
+ git -C $_pkgname describe --long --tags | sed 's/^v//;s/\([^-]*-\)g/r\1/;s/-/./g'
+}
+
+build() {
+ _setup
+
+ PATH="$_path" nimble install -l --verbose --passNim:--passC:"\"$CFLAGS\"" --passNim:--passL:"\"$LDFLAGS\""
+}
+
+package() {
+ install -Dm755 $_pkgname/hpx -t "$pkgdir/usr/bin/"
+}