summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndré Löfgren2021-09-14 15:22:29 +0200
committerAndré Löfgren2021-09-14 15:22:29 +0200
commit179deda7706cba51e1b6e967e5818fe76bcdc21b (patch)
tree350b7013181ab182820c9b8db061beff3c256b7b
downloadaur-179deda7706cba51e1b6e967e5818fe76bcdc21b.tar.gz
Initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD57
-rw-r--r--harbour-amazfish-git.pro2
3 files changed, 81 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ad4e8d7c5ef9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = harbour-amazfish-git
+ pkgdesc = Companion application for Huami Devices and the Pinetime Infinitime
+ pkgver = r849.34365e4
+ pkgrel = 1
+ url = https://github.com/piggz/harbour-amazfish
+ arch = x86_64
+ arch = aarch64
+ license = AGPL3
+ depends = qt5-base
+ depends = kdb
+ depends = kcontacts
+ depends = kcoreaddons
+ depends = qt5-location
+ depends = qt5-connectivity
+ depends = qtmpris
+ depends = nemo-qml-plugin-dbus
+ provides = harbour-amazfish
+ conflicts = harbour-amazfish-git
+ source = git+https://github.com/piggz/harbour-amazfish
+ md5sums = SKIP
+
+pkgname = harbour-amazfish-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e38b0147a36e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,57 @@
+# Maintainer: Ikosse <andrelofgren@hotmail.co.uk>
+
+pkgname=harbour-amazfish-git
+pkgver=r849.34365e4
+pkgrel=1
+epoch=
+pkgdesc="Companion application for Huami Devices and the Pinetime Infinitime"
+arch=(x86_64 aarch64)
+url="https://github.com/piggz/harbour-amazfish"
+license=('AGPL3')
+groups=()
+depends=(
+ 'qt5-base'
+ 'kdb'
+ 'kcontacts'
+ 'kcoreaddons'
+ 'qt5-location'
+ 'qt5-connectivity'
+ 'qtmpris'
+ 'nemo-qml-plugin-dbus'
+)
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=(harbour-amazfish)
+conflicts=(harbour-amazfish-git)
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=(git+$url)
+noextract=()
+md5sums=('SKIP')
+validpgpkeys=()
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$srcdir/${pkgname%-git}"
+ git submodule init
+ git submodule update
+}
+
+build() {
+ cd "$srcdir/${pkgname%-git}"
+ qmake FLAVOR=kirigami PREFIX=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ make INSTALL_ROOT="$pkgdir" install
+}
diff --git a/harbour-amazfish-git.pro b/harbour-amazfish-git.pro
new file mode 100644
index 000000000000..1b50fdb1c356
--- /dev/null
+++ b/harbour-amazfish-git.pro
@@ -0,0 +1,2 @@
+target.path = /usr/bin
+INSTALLS += target