summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Whitwell2021-02-25 11:48:23 +0000
committerTom Whitwell2021-02-25 11:48:23 +0000
commitc81a4d86b6a5fb0e4fbdccf5c93d121b4fc26350 (patch)
treef8ac72a0b23c1dc275d45c2cefdfdb46751b929c
parent5093c7a3913451eebb42b907445de02aff911947 (diff)
downloadaur-c81a4d86b6a5fb0e4fbdccf5c93d121b4fc26350.tar.gz
Add patch for signal provided by DTHCND
-rw-r--r--.SRCINFO2
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD7
-rw-r--r--hardcode-tray.patch16
4 files changed, 24 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8b723d8c5fa7..90fd4b48ed5d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = hardcode-tray
pkgdesc = Fixes Hardcoded Tray Icons
pkgver = 4.3
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/bil-elmoussaoui/Hardcode-Tray
arch = i686
arch = x86_64
diff --git a/.gitignore b/.gitignore
index 93f5d9f2777e..9e2fa298c333 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,3 +2,4 @@ pkg/
src/
*.tar.gz
*.tar.xz
+*.tar.zst
diff --git a/PKGBUILD b/PKGBUILD
index 99913d6c9d27..1b30b1956c7f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ _pkgbase=hardcode-tray
_gitname=Hardcode-Tray
pkgname=$_pkgbase
pkgver=4.3
-pkgrel=1
+pkgrel=2
pkgdesc="Fixes Hardcoded Tray Icons"
arch=('i686' 'x86_64')
url="https://github.com/bil-elmoussaoui/${_gitname}"
@@ -19,6 +19,11 @@ optdepends_x86_64=('lib32-sni-qt-patched-git: 32-bit patched qt4 sni plugin to e
source=("${url}/archive/v${pkgver}.tar.gz")
sha256sums=('5f64c5a1083b8cefc07ba3a218bb0258f7846d9c0d04dae6f91c2478e288f0e1')
+prepare() {
+ cd "$srcdir"
+ cp ../hardcode-tray.patch .
+ patch --forward --strip=1 --input="${srcdir}/hardcode-tray.patch"
+}
build() {
cd "$srcdir/${_gitname}-${pkgver}"
diff --git a/hardcode-tray.patch b/hardcode-tray.patch
new file mode 100644
index 000000000000..c97d2d6efc2f
--- /dev/null
+++ b/hardcode-tray.patch
@@ -0,0 +1,16 @@
+diff --unified --recursive --text package.old/Hardcode-Tray-4.3/data/database/signal.json package.new/Hardcode-Tray-4.3/data/database/signal.json
+--- package.old/Hardcode-Tray-4.3/data/database/signal.json 2018-02-22 14:43:14.000000000 -0500
++++ package.new/Hardcode-Tray-4.3/data/database/signal.json 2021-02-23 00:44:02.707356772 -0500
+@@ -1,10 +1,10 @@
+ {
+ "name": "Signal",
+ "app_path": [
+- "/opt/Signal/"
++ "/usr/lib/signal-desktop/"
+ ],
+ "icons_path": [
+- "/opt/Signal/resources/"
++ "/usr/lib/signal-desktop/resources/"
+ ],
+ "binary": "app.asar",
+ "script": "electron",