summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorQuentin Retornaz2016-10-31 02:22:15 +0100
committerQuentin Retornaz2016-10-31 02:22:15 +0100
commit12f3655521e25ff373c1315f512517c3e49ceb0a (patch)
tree6550e8133f0c81a03bf9612e9cb542bdc425ab1b
downloadaur-12f3655521e25ff373c1315f512517c3e49ceb0a.tar.gz
hardened-fox r383.30107c0-1
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD28
-rw-r--r--local-settings.js2
3 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..32605db0278f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Mon Oct 31 01:20:27 UTC 2016
+pkgbase = hardened-fox
+ pkgdesc = Firefox configuration to harden privacy.
+ pkgver = r383.30107c0
+ pkgrel = 1
+ url = https://github.com/pyllyukko/user.js
+ arch = any
+ license = MIT
+ depends = firefox
+ source = git+https://github.com/pyllyukko/user.js.git
+ source = local-settings.js
+ sha512sums = SKIP
+ sha512sums = 3cd84d8aecc69634cc06b7a5368ee027114cc254afdf4596dbe99d93c7ee7c497bb5f7ca528c56d129241c6adacaba9d9a62ee45631c482bd54007789a9e73b2
+
+pkgname = hardened-fox
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1b6ab6f160ae
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+pkgname=hardened-fox
+_pkgname=user.js
+pkgver=r383.30107c0
+pkgrel=1
+pkgdesc="Firefox configuration to harden privacy."
+arch=('any')
+url="https://github.com/pyllyukko/user.js"
+license=('MIT')
+depends=('firefox')
+source=(git+"https://github.com/pyllyukko/user.js.git"
+ local-settings.js)
+sha512sums=('SKIP'
+ '3cd84d8aecc69634cc06b7a5368ee027114cc254afdf4596dbe99d93c7ee7c497bb5f7ca528c56d129241c6adacaba9d9a62ee45631c482bd54007789a9e73b2')
+
+pkgver() {
+ cd ${_pkgname}
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd ${_pkgname}
+ sed -i -e '1s/^/\/\/\n/' -e 's/user_pref/lockPref/g' user.js
+}
+
+package() {
+ install -Dm644 ${srcdir}/local-settings.js ${pkgdir}/usr/lib/firefox/defaults/pref/local-settings.js
+ install -Dm644 ${srcdir}/${_pkgname}/user.js ${pkgdir}/usr/lib/firefox/mozilla.cfg
+}
diff --git a/local-settings.js b/local-settings.js
new file mode 100644
index 000000000000..87d65796deeb
--- /dev/null
+++ b/local-settings.js
@@ -0,0 +1,2 @@
+pref("general.config.obscure_value", 0);
+pref("general.config.filename", "mozilla.cfg"); \ No newline at end of file