summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorQuentin Retornaz2016-10-31 21:30:25 +0100
committerQuentin Retornaz2016-10-31 21:30:25 +0100
commit77429a439863859d494149f8c443178127ac1b26 (patch)
treee7402058becdfbe821ded6b5d39f78a6659df721
parent12f3655521e25ff373c1315f512517c3e49ceb0a (diff)
downloadaur-77429a439863859d494149f8c443178127ac1b26.tar.gz
PKGBUILD improvements
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD19
2 files changed, 11 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 32605db0278f..107a44c2b719 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Mon Oct 31 01:20:27 UTC 2016
+# Mon Oct 31 20:29:06 UTC 2016
pkgbase = hardened-fox
pkgdesc = Firefox configuration to harden privacy.
pkgver = r383.30107c0
@@ -8,7 +8,7 @@ pkgbase = hardened-fox
arch = any
license = MIT
depends = firefox
- source = git+https://github.com/pyllyukko/user.js.git
+ source = user.js.git::git+https://github.com/pyllyukko/user.js.git
source = local-settings.js
sha512sums = SKIP
sha512sums = 3cd84d8aecc69634cc06b7a5368ee027114cc254afdf4596dbe99d93c7ee7c497bb5f7ca528c56d129241c6adacaba9d9a62ee45631c482bd54007789a9e73b2
diff --git a/PKGBUILD b/PKGBUILD
index 1b6ab6f160ae..7b57629a6a5f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,27 @@
pkgname=hardened-fox
-_pkgname=user.js
pkgver=r383.30107c0
pkgrel=1
-pkgdesc="Firefox configuration to harden privacy."
+pkgdesc='Firefox configuration to harden privacy.'
arch=('any')
-url="https://github.com/pyllyukko/user.js"
+url='https://github.com/pyllyukko/user.js'
license=('MIT')
depends=('firefox')
-source=(git+"https://github.com/pyllyukko/user.js.git"
- local-settings.js)
+source=('user.js.git::git+https://github.com/pyllyukko/user.js.git'
+ 'local-settings.js')
sha512sums=('SKIP'
'3cd84d8aecc69634cc06b7a5368ee027114cc254afdf4596dbe99d93c7ee7c497bb5f7ca528c56d129241c6adacaba9d9a62ee45631c482bd54007789a9e73b2')
pkgver() {
- cd ${_pkgname}
+ cd "$srcdir/user.js.git"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
prepare() {
- cd ${_pkgname}
- sed -i -e '1s/^/\/\/\n/' -e 's/user_pref/lockPref/g' user.js
+ cd "$srcdir/user.js.git"
+ sed -i -e '1s#^#//\n#' -e 's/user_pref/lockPref/g' user.js
}
package() {
- install -Dm644 ${srcdir}/local-settings.js ${pkgdir}/usr/lib/firefox/defaults/pref/local-settings.js
- install -Dm644 ${srcdir}/${_pkgname}/user.js ${pkgdir}/usr/lib/firefox/mozilla.cfg
+ install -Dm644 "$srcdir/local-settings.js" "$pkgdir/usr/lib/firefox/defaults/pref/local-settings.js"
+ install -Dm644 "$srcdir/user.js.git/user.js" "$pkgdir/usr/lib/firefox/mozilla.cfg"
}