summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThibaut Sautereau2022-01-04 13:13:01 +0100
committerThibaut Sautereau2022-01-04 13:13:01 +0100
commit1d410966e206034c68d4f730654bfbce37b840c8 (patch)
tree4caed2f281604f2c62e7342c0a6a0dcc4d2a0b58
parentd757f2fefff5e768439a3a5219ec95b53652211b (diff)
downloadaur-1d410966e206034c68d4f730654bfbce37b840c8.tar.gz
Bump to version 9
See https://github.com/GrapheneOS/hardened_malloc/compare/8...9 for full list of changes from the previous release (version 8).
-rw-r--r--.SRCINFO8
-rw-r--r--0001-Fix-CPPFLAGS-in-test-Makefile.patch31
-rw-r--r--PKGBUILD14
3 files changed, 7 insertions, 46 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 59b34512e9bc..42a764d061ed 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = hardened_malloc
pkgdesc = Hardened allocator designed for modern systems
- pkgver = 8
- pkgrel = 2
+ pkgver = 9
+ pkgrel = 1
url = https://github.com/GrapheneOS/hardened_malloc
arch = x86_64
license = MIT
@@ -9,10 +9,8 @@ pkgbase = hardened_malloc
makedepends = git
depends = gcc-libs
provides = libhardened_malloc.so
- source = git+https://github.com/GrapheneOS/hardened_malloc#tag=8?signed
- source = 0001-Fix-CPPFLAGS-in-test-Makefile.patch
+ source = git+https://github.com/GrapheneOS/hardened_malloc#tag=9?signed
validpgpkeys = 65EEFE022108E2B708CBFCF7F9E712E59AF5F22A
sha256sums = SKIP
- sha256sums = 118692a4096a70401773def95be713f535ae04477e2eb73e59b03169d54ea635
pkgname = hardened_malloc
diff --git a/0001-Fix-CPPFLAGS-in-test-Makefile.patch b/0001-Fix-CPPFLAGS-in-test-Makefile.patch
deleted file mode 100644
index 22dd89b67058..000000000000
--- a/0001-Fix-CPPFLAGS-in-test-Makefile.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From a33d2ca97d119ef657207fc27248db4c3103531f Mon Sep 17 00:00:00 2001
-From: Thibaut Sautereau <thibaut@sautereau.fr>
-Date: Tue, 2 Nov 2021 20:22:05 +0100
-Subject: [PATCH] Fix CPPFLAGS in test Makefile
-
-In particular, the _GNU_SOURCE feature test macro needs to be set in
-order to correctly define mmap(2) flags such as MAP_ANONYMOUS.
-Otherwise, compilation of some test files fails when CPPFLAGS is not
-defined in the initial user environment, as Make then does not export it
-from the root Makefile to the sub-make.
----
- test/simple-memory-corruption/Makefile | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/test/simple-memory-corruption/Makefile b/test/simple-memory-corruption/Makefile
-index 609677e7e670..d217b4806565 100644
---- a/test/simple-memory-corruption/Makefile
-+++ b/test/simple-memory-corruption/Makefile
-@@ -6,7 +6,8 @@ ifeq (,$(filter $(CONFIG_SLAB_CANARY),true false))
- $(error CONFIG_SLAB_CANARY must be true or false)
- endif
-
--CFLAGS += -DSLAB_CANARY=$(CONFIG_SLAB_CANARY)
-+CPPFLAGS += -D_GNU_SOURCE \
-+ -DSLAB_CANARY=$(CONFIG_SLAB_CANARY)
-
- LDLIBS := -lhardened_malloc
-
---
-2.33.1
-
diff --git a/PKGBUILD b/PKGBUILD
index a7f44ceb3a34..00a0d81de3ef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Thibaut Sautereau (thithib) <thibaut at sautereau dot fr>
pkgname=hardened_malloc
-pkgver=8
-pkgrel=2
+pkgver=9
+pkgrel=1
pkgdesc="Hardened allocator designed for modern systems"
arch=('x86_64')
url="https://github.com/GrapheneOS/hardened_malloc"
@@ -11,16 +11,10 @@ depends=('gcc-libs')
makedepends=('git')
checkdepends=('python')
provides=('libhardened_malloc.so')
-source=("git+https://github.com/GrapheneOS/$pkgname#tag=$pkgver?signed"
- '0001-Fix-CPPFLAGS-in-test-Makefile.patch')
-sha256sums=('SKIP'
- '118692a4096a70401773def95be713f535ae04477e2eb73e59b03169d54ea635')
+source=("git+https://github.com/GrapheneOS/$pkgname#tag=$pkgver?signed")
+sha256sums=('SKIP')
validpgpkeys=('65EEFE022108E2B708CBFCF7F9E712E59AF5F22A') # Daniel Micay <danielmicay@gmail.com>
-prepare() {
- patch --directory="$pkgname" --input="$srcdir/0001-Fix-CPPFLAGS-in-test-Makefile.patch" --strip=1
-}
-
build() {
cd "$pkgname"
make