summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThibaut Sautereau2020-09-19 23:00:36 +0200
committerThibaut Sautereau2020-09-19 23:12:07 +0200
commitb5469f92aafa0b900b0c0e34d112659c2b1d874a (patch)
treeab9a4479f60e279b8d627ae1bf6c136ea7126fdf
parentc54df0396359c0d7af8515159d8623bc1c0df520 (diff)
downloadaur-b5469f92aafa0b900b0c0e34d112659c2b1d874a.tar.gz
Bump to version 3
See https://github.com/GrapheneOS/hardened_malloc/compare/2...3 for full list of changes from the previous release (version 2). Also, make explicit what external shared library is provided by the package, in compliance with the Arch package guidelines, and add tests.
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD11
2 files changed, 14 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fb633c206a29..42e172ab9526 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,15 @@
pkgbase = hardened_malloc
pkgdesc = Hardened allocator designed for modern systems
- pkgver = 2
- pkgrel = 2
+ pkgver = 3
+ pkgrel = 1
url = https://github.com/GrapheneOS/hardened_malloc
arch = x86_64
license = MIT
+ checkdepends = python
makedepends = git
+ provides = libhardened_malloc.so-64
conflicts = hardened-malloc-git
- source = git+https://github.com/GrapheneOS/hardened_malloc#tag=2?signed
+ source = git+https://github.com/GrapheneOS/hardened_malloc#tag=3?signed
validpgpkeys = 65EEFE022108E2B708CBFCF7F9E712E59AF5F22A
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 2b799f04bed5..705545d9eef2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,15 @@
# Maintainer: Thibaut Sautereau (thithib) <thibaut at sautereau dot fr>
pkgname=hardened_malloc
-pkgver=2
-pkgrel=2
+pkgver=3
+pkgrel=1
pkgdesc="Hardened allocator designed for modern systems"
arch=('x86_64')
url="https://github.com/GrapheneOS/hardened_malloc"
license=('MIT')
makedepends=('git')
+checkdepends=('python')
+provides=('libhardened_malloc.so-64')
conflicts=('hardened-malloc-git')
source=("git+https://github.com/GrapheneOS/$pkgname#tag=$pkgver?signed")
sha256sums=('SKIP')
@@ -18,6 +20,11 @@ build() {
make
}
+check() {
+ cd "$pkgname"
+ make CONFIG_WERROR=false test
+}
+
package() {
cd "$pkgname"
install -Dm755 --target-directory="$pkgdir/usr/lib" libhardened_malloc.so