summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorent H. CARRÉ2015-07-18 22:49:54 +0200
committerFlorent H. CARRÉ2015-07-18 22:49:54 +0200
commit260cb383f8625503e35c50333e0987e2f50bd62f (patch)
treebfc60a0eb2e961d0fce98385f91ff485a2d3bf20
downloadaur-260cb383f8625503e35c50333e0987e2f50bd62f.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD31
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dceb282df55e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = hardening-check
+ pkgdesc = Check binaries for security hardening features
+ pkgver = 2.7
+ pkgrel = 1
+ url = http://wiki.debian.org/Hardening
+ arch = any
+ license = GPL2
+ depends = bash
+ depends = perl
+ source = http://ftp.de.debian.org/debian/pool/main/h/hardening-wrapper/hardening-wrapper_2.7.tar.xz
+ source = http://ftp.de.debian.org/debian/pool/main/h/hardening-wrapper/hardening-wrapper_2.7.dsc
+ sha256sums = 20c601c6ccac7534d17d4be9442a4ad8f02b8461c2c50dee8b45d596cd6cf8e7
+ sha256sums = a41080316928a0e086a622dcdae12fefb45abbaec6c435fa98e39754dfe64d79
+
+pkgname = hardening-check
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..12cb66d4d0fc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer : Florent H. CARRÉ <colundrum@gmail.com>
+
+pkgname=hardening-check
+_pkgname=hardening-wrapper
+pkgver=2.7
+pkgrel=1
+pkgdesc="Check binaries for security hardening features"
+arch=('any')
+url="http://wiki.debian.org/Hardening"
+license=('GPL2')
+depends=('bash' 'perl')
+source=("http://ftp.de.debian.org/debian/pool/main/h/hardening-wrapper/hardening-wrapper_$pkgver"{.tar.xz,.dsc})
+sha256sums=('20c601c6ccac7534d17d4be9442a4ad8f02b8461c2c50dee8b45d596cd6cf8e7'
+ 'a41080316928a0e086a622dcdae12fefb45abbaec6c435fa98e39754dfe64d79')
+
+build() {
+ cd "$srcdir/$_pkgname"
+
+ # Irrelevant, we don't ship the wrappers.
+ make DEB_HOST_ARCH_OS=amd64 DEB_HOST_ARCH=amd64
+}
+
+package() {
+ cd "$srcdir/$_pkgname/build-tree"
+ install -Dm0755 'hardening-check' "$pkgdir/usr/bin/hardening-check"
+ install -Dm0755 '../hardening-check.sh' "$pkgdir/usr/bin/hardening-check.sh"
+ install -Dm0755 'hardening-check.1' "$pkgdir/usr/share/man/man1/hardening-check.1" \
+ && chmod -c 0444 "$pkgdir/usr/share/man/man1/hardening-check.1"
+}
+
+# vim:set ts=2 sw=2 et: