summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2022-04-29 09:08:09 -0600
committerMark Wagie2022-04-29 09:08:09 -0600
commit8c7d29c286f7c011f414dac100c3c4c790eaec7b (patch)
treed75141af10fad4f2e685842644fbb13f8128f420
parent2e69f8723f2e6fc2d47b3f7b0aaeb50854013cfc (diff)
downloadaur-8c7d29c286f7c011f414dac100c3c4c790eaec7b.tar.gz
add patch to fix benchmarks
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD10
-rw-r--r--benchmark.patch15
4 files changed, 26 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 493a07bc873a..7a83d40360bc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = hardinfo-git
pkgdesc = A system information and benchmark tool.
pkgver = 0.6.alpha.1392.g6ecebbd
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/lpereira/hardinfo
arch = x86_64
license = GPL2
@@ -19,6 +19,8 @@ pkgbase = hardinfo-git
conflicts = hardinfo
options = debug
source = git+https://github.com/lpereira/hardinfo.git
+ source = benchmark.patch
sha256sums = SKIP
+ sha256sums = 5a352377abce848dbb20b5e35d86feba9b62011d1a7cd075c0d14d54e91f3286
pkgname = hardinfo-git
diff --git a/.gitignore b/.gitignore
index 4dab8d6386e3..034de42d4373 100644
--- a/.gitignore
+++ b/.gitignore
@@ -5,3 +5,4 @@
!.gitignore
!PKGBUILD
!.SRCINFO
+!benchmark.patch
diff --git a/PKGBUILD b/PKGBUILD
index 392e962989c8..ec60816b172f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Eric BĂ©langer <eric at archlinux dot org>
pkgname=hardinfo-git
pkgver=0.6.alpha.1392.g6ecebbd
-pkgrel=3
+pkgrel=4
pkgdesc="A system information and benchmark tool."
arch=('x86_64')
url="https://github.com/lpereira/hardinfo"
@@ -18,8 +18,10 @@ optdepends=('dmidecode: Memory Devices module'
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
options=('debug')
-source=('git+https://github.com/lpereira/hardinfo.git')
-sha256sums=('SKIP')
+source=('git+https://github.com/lpereira/hardinfo.git'
+ 'benchmark.patch')
+sha256sums=('SKIP'
+ '5a352377abce848dbb20b5e35d86feba9b62011d1a7cd075c0d14d54e91f3286')
pkgver() {
cd "$srcdir/${pkgname%-git}"
@@ -29,6 +31,8 @@ pkgver() {
prepare() {
cd "$srcdir/${pkgname%-git}"
+ patch -Np1 -i ../benchmark.patch
+
# ignore odr-violation errors
# setconf "${pkgname%-git}.desktop.cmake" Exec \
# "sh -c 'env ASAN_OPTIONS=detect_odr_violation=0 @CMAKE_INSTALL_FULL_BINDIR@/hardinfo'"
diff --git a/benchmark.patch b/benchmark.patch
new file mode 100644
index 000000000000..9aa92d5f8939
--- /dev/null
+++ b/benchmark.patch
@@ -0,0 +1,15 @@
+diff --git a/modules/benchmark.c b/modules/benchmark.c
+index 50ba7d2..eb8e111 100644
+--- a/modules/benchmark.c
++++ b/modules/benchmark.c
+@@ -620,9 +620,7 @@ static void do_benchmark(void (*benchmark_function)(void), int entry)
+ return;
+
+ if (params.gui_running) {
+- gchar *argv[] = {params.argv0, "-b", entries[entry].name,
+- "-m", "benchmark.so", "-a",
+- NULL};
++ gchar *argv[] = {params.argv0, "-b", entries[entry].name, "-m", "devices.so", "-m", "benchmark.so", "-a", NULL};
+ GPid bench_pid;
+ gint bench_stdout;
+ GtkWidget *bench_dialog;