summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArmin Preiml2023-08-01 16:48:47 +0200
committerArmin Preiml2023-08-01 16:50:08 +0200
commit263ee48b428d93a4aeae945e0241039bb5e62e76 (patch)
tree78f3ffbde9c270f75ccc7edda6b58c709ad00841
parent37d61777202f83de43119ce5a64e9167b4b9efc7 (diff)
downloadaur-263ee48b428d93a4aeae945e0241039bb5e62e76.tar.gz
remove patch that disables failing tests on aarch64
-rw-r--r--.SRCINFO2
-rw-r--r--0001-Comment-out-assertions-that-fail-on-aarch64.patch94
-rw-r--r--PKGBUILD4
3 files changed, 1 insertions, 99 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 60317bef2a8f..4ef25d5e573e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -17,11 +17,9 @@ pkgbase = hare-git
provides = hare
conflicts = hare
source = hare::git+https://git.sr.ht/~sircmpwn/hare
- source = 0001-Comment-out-assertions-that-fail-on-aarch64.patch
source = config.x86_64.mk
source = config.aarch64.mk
sha256sums = SKIP
- sha256sums = 3511a8499adbd53cf18379aeda3ef739a90e70fb2fe2f02477b5652d7ad63d06
sha256sums = 9c339eeb042ce00641cea4eed5403ca204d6f4f9cd5f709be286a252db47a034
sha256sums = c82db335b70c03d3d656128fbb0be2cc552219b3e7c93b15d1e6afd1b0e9ba7e
diff --git a/0001-Comment-out-assertions-that-fail-on-aarch64.patch b/0001-Comment-out-assertions-that-fail-on-aarch64.patch
deleted file mode 100644
index 9f8736431523..000000000000
--- a/0001-Comment-out-assertions-that-fail-on-aarch64.patch
+++ /dev/null
@@ -1,94 +0,0 @@
-From 154321fac116d0edc7e2a5f2993e980f64704864 Mon Sep 17 00:00:00 2001
-From: Drew DeVault <sir@cmpwn.com>
-Date: Wed, 1 Feb 2023 12:44:17 +0100
-Subject: [PATCH hare] Comment out assertions that fail on aarch64
-
-See #766
-
-I really would prefer not to do this, but these bugs are a bitch. I
-can't reproduce them on any of my aarch64 machines and it's totally
-non-obvious what might be causing them. Because they don't fail on every
-aarch64 machine I can get my hands on, I am reluctantly willing to
-disable them on the basis that they /probably/ work for most people.
-
-References: https://todo.sr.ht/~sircmpwn/hare/766
----
- crypto/math/bits.ha | 3 ++-
- math/ints.ha | 6 ++++--
- math/uints.ha | 7 ++++---
- strconv/+test/stoi.ha | 3 ++-
- 4 files changed, 12 insertions(+), 7 deletions(-)
-
-diff --git a/crypto/math/bits.ha b/crypto/math/bits.ha
-index 0c697e67..c37d2649 100644
---- a/crypto/math/bits.ha
-+++ b/crypto/math/bits.ha
-@@ -38,7 +38,8 @@ export fn rotr64(x: u64, k: int) u64 = rotl64(x, -k);
- @test fn lrot64() void = {
- let a = 1u64;
- assert(rotl64(a, 1) == 0b10);
-- assert(rotl64(a, -1) == 0b1000000000000000000000000000000000000000000000000000000000000000);
-+ // XXX aarch64: https://todo.sr.ht/~sircmpwn/hare/766
-+ //assert(rotl64(a, -1) == 0b1000000000000000000000000000000000000000000000000000000000000000);
- assert(rotl64(a, 39) == (1u64 << 39));
-
- let a = 0b1111000011110000111100001111000011110000111100001111000011110000u64;
-diff --git a/math/ints.ha b/math/ints.ha
-index 8d772324..7d459127 100644
---- a/math/ints.ha
-+++ b/math/ints.ha
-@@ -76,7 +76,8 @@ export fn absi(n: types::integer) u64 = {
- assert(absi32(types::I32_MIN) == m32);
- assert(absi64(2i64) == 2u64);
- assert(absi64(-2i64) == 2u64);
-- assert(absi64(types::I64_MIN) == m64);
-+ // XXX aarch64: https://todo.sr.ht/~sircmpwn/hare/766
-+ //assert(absi64(types::I64_MIN) == m64);
- assert(absi(2i8) == 2u64);
- assert(absi(-2i8) == 2u64);
- assert(absi(types::I8_MIN) == (m8: u64));
-@@ -88,7 +89,8 @@ export fn absi(n: types::integer) u64 = {
- assert(absi(types::I32_MIN) == (m32: u64));
- assert(absi(2i64) == 2u64);
- assert(absi(-2i64) == 2u64);
-- assert(absi(types::I64_MIN) == (m64: u64));
-+ // XXX aarch64: https://todo.sr.ht/~sircmpwn/hare/766
-+ //assert(absi(types::I64_MIN) == (m64: u64));
- };
-
- // Return 1 if n is positive, -1 if it's negative and 0 if it's 0.
-diff --git a/math/uints.ha b/math/uints.ha
-index a12b250c..f48ae546 100644
---- a/math/uints.ha
-+++ b/math/uints.ha
-@@ -612,9 +612,10 @@ export fn divu(hi: uint, lo: uint, y: uint) (uint, uint) = {
- let res = divu64(0u64, 5u64, 2u64);
- assert(res.0 == 2u64);
- assert(res.1 == 1u64);
-- let res = divu64(1u64, 0u64, 2u64);
-- assert(res.0 == (1u64 << 63));
-- assert(res.1 == 0u64);
-+ // XXX aarch64: https://todo.sr.ht/~sircmpwn/hare/766
-+ //let res = divu64(1u64, 0u64, 2u64);
-+ //assert(res.0 == (1u64 << 63));
-+ //assert(res.1 == 0u64);
- // These should panic.
- // let res = divu64(1u64, 1u64, 0u64);
- // let res = divu64(1u64, 0u64, 1u64);
-diff --git a/strconv/+test/stoi.ha b/strconv/+test/stoi.ha
-index 363abd89..e1c35aad 100644
---- a/strconv/+test/stoi.ha
-+++ b/strconv/+test/stoi.ha
-@@ -18,7 +18,8 @@ use types;
- assert(stoi64("+1") as i64 == 1);
- assert(stoi64("-1") as i64 == -1);
- assert(stoi64("9223372036854775807") as i64 == types::I64_MAX);
-- assert(stoi64("-9223372036854775808") as i64 == types::I64_MIN);
-+ // XXX aarch64: https://todo.sr.ht/~sircmpwn/hare/766
-+ //assert(stoi64("-9223372036854775808") as i64 == types::I64_MIN);
-
- assert(stoi32("2147483648") is overflow);
- assert(stoi32("-2147483649") is overflow);
---
-2.39.1
-
diff --git a/PKGBUILD b/PKGBUILD
index f9dffbfa2bac..02c90b2e6817 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Armin Preiml <apreiml@strohwolke.at>
pkgname=hare-git
_pkgname=hare
-pkgver=r2873.b76e834c
+pkgver=r3158.8b5284b6
pkgrel=1
license=("MPL2")
pkgdesc="The Hare systems programming language"
@@ -25,7 +25,6 @@ optdepends=(
arch=("x86_64" "aarch64")
url="https://harelang.org"
source=("${pkgname%-*}::git+https://git.sr.ht/~sircmpwn/hare"
- 0001-Comment-out-assertions-that-fail-on-aarch64.patch
config.x86_64.mk
config.aarch64.mk)
@@ -69,6 +68,5 @@ package() {
}
sha256sums=('SKIP'
- '3511a8499adbd53cf18379aeda3ef739a90e70fb2fe2f02477b5652d7ad63d06'
'9c339eeb042ce00641cea4eed5403ca204d6f4f9cd5f709be286a252db47a034'
'c82db335b70c03d3d656128fbb0be2cc552219b3e7c93b15d1e6afd1b0e9ba7e')