summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArmin Preiml2023-04-19 10:54:28 +0200
committerArmin Preiml2023-04-19 10:54:28 +0200
commit37d61777202f83de43119ce5a64e9167b4b9efc7 (patch)
tree66ce6374aae47b37e59f4eecc64fb585f1c1f6c7
parentf65611a54033550ab583f4a5f5f1b1d88ca55abf (diff)
downloadaur-37d61777202f83de43119ce5a64e9167b4b9efc7.tar.gz
update to the new LDLINKFLAGS option
-rw-r--r--PKGBUILD8
1 files changed, 3 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fdcd733e1060..f9dffbfa2bac 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Armin Preiml <apreiml@strohwolke.at>
pkgname=hare-git
_pkgname=hare
-pkgver=r2824.77613ea2
+pkgver=r2873.b76e834c
pkgrel=1
license=("MPL2")
pkgdesc="The Hare systems programming language"
@@ -50,10 +50,8 @@ build() {
export VERSION="dev+$(echo "$_commit" | cut -c-7)"
export LOCALVER=arch
- # remove '-Wl,' prefix if present, since it is only required when
- # the linker is invoked indirectly. Keeping it will cause the linker to
- # fail.
- export LDFLAGS=${LDFLAGS#"-Wl,"}
+ # remove '-Wl,' prefix if present as hare requires direct link flags
+ export LDLINKFLAGS=${LDFLAGS#"-Wl,"}
make -j1 # XXX: parallel build driver builds are broken
}