summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGeorge Rawlinson2022-05-10 22:10:12 +1200
committerGeorge Rawlinson2022-05-10 22:10:12 +1200
commit9ac34d98e9557059570bfe67f5ec47cfcfcb0d8c (patch)
treea0bf925928570569677e9859e9843314908d2c91
downloadaur-9ac34d98e9557059570bfe67f5ec47cfcfcb0d8c.tar.gz
addpkg: hare-ssh r36-1
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD39
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..88431588f3d7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = hare-ssh
+ pkgdesc = SSH library for Hare
+ pkgver = r36.e33ffce
+ pkgrel = 1
+ url = https://git.sr.ht/~sircmpwn/hare-ssh
+ arch = any
+ license = MPL2
+ makedepends = git
+ depends = hare
+ source = hare-ssh::git+https://git.sr.ht/~sircmpwn/hare-ssh#commit=e33ffce51a9a5062959f6fa3d6fa51e52e13c490
+ md5sums = SKIP
+
+pkgname = hare-ssh
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..27c6bd40da74
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: George Rawlinson <grawlinson@archlinux.org>
+
+pkgname=hare-ssh
+pkgver=r36.e33ffce
+pkgrel=1
+pkgdesc='SSH library for Hare'
+arch=('any')
+url='https://git.sr.ht/~sircmpwn/hare-ssh'
+license=('MPL2')
+depends=('hare')
+makedepends=('git')
+_commit='e33ffce51a9a5062959f6fa3d6fa51e52e13c490'
+source=("$pkgname::git+$url#commit=$_commit")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$pkgname"
+
+ sed \
+ -i Makefile \
+ -e 's/install -m644/cp -vr/g'
+}
+check() {
+ cd "$pkgname"
+
+ make check
+}
+
+package() {
+ cd "$pkgname"
+
+ make DESTDIR="$pkgdir" PREFIX=/usr install
+}