summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArmin Preiml2023-02-02 15:03:47 +0100
committerArmin Preiml2023-02-02 15:03:47 +0100
commit189b5597e2dc0af7233f44c1f33831f2189b2c6e (patch)
tree8994156ca608b456bc72ae444a1aa370da87f1e1
parent0bf4750773e63e278a308010b66a439f4f52f429 (diff)
downloadaur-189b5597e2dc0af7233f44c1f33831f2189b2c6e.tar.gz
change build system to haredo
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD11
2 files changed, 7 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b1cc341edca5..c5f7f07f330f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = haredump-git
pkgdesc = Command line tool that dumps data as hare code.
- pkgver = r7.6f5378e
+ pkgver = r11.e5740bc
pkgrel = 1
url = https://git.sr.ht/~autumnull/haredump
arch = x86_64
arch = aarch64
- license = custom
+ license = custom:WTFPL
makedepends = hare
+ makedepends = haredo
makedepends = git
provides = haredump
conflicts = haredump
diff --git a/PKGBUILD b/PKGBUILD
index fd9b2cf89a25..500aca966fdb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,13 @@
# Maintainer: Armin Preiml <apreiml@strohwolke.at>
pkgname=haredump-git
_pkgname=haredump
-pkgver=r7.6f5378e
+pkgver=r11.e5740bc
pkgrel=1
license=("custom:WTFPL")
pkgdesc="Command line tool that dumps data as hare code."
makedepends=(
"hare"
+ "haredo"
"git"
)
@@ -26,17 +27,13 @@ pkgver() {
build() {
cd "$srcdir/$_pkgname"
-
- # remove '-Wl,' prefix if present, since it is only required when the
- # linker is invoked indirectly. Keeping it will cause the linker to
- # fail.
- make LDFLAGS=${LDFLAGS#"-Wl,"}
+ haredo
}
package() {
cd "$srcdir/$_pkgname"
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$_pkgname/LICENSE"
- make PREFIX="$pkgdir/usr" install
+ PREFIX="$pkgdir/usr" haredo install
}