summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKamran Mackey2015-12-14 19:34:22 -0700
committerKamran Mackey2015-12-14 19:34:22 -0700
commitbd765cf8d0ef72ac904ebc63d5f4a5b30196a748 (patch)
tree7756e7e06165812b4ca253e02229e0e0762fd610
parent388941aa75e67025a188c3c5652e28cb248c763e (diff)
downloadaur-bd765cf8d0ef72ac904ebc63d5f4a5b30196a748.tar.gz
Fixed the package functions.
Signed-off-by: Kamran Mackey <kamranm1200@gmail.com>
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD6
2 files changed, 11 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5b3908d9b826..6dd2b08c1ce8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Mon Dec 14 17:00:53 UTC 2015
+# Tue Dec 15 02:34:15 UTC 2015
pkgbase = harfbuzz-git
pkgdesc = OpenType text shaping engine (git version)
pkgver = 1.1.2.r19.g15f2c05
@@ -22,6 +22,13 @@ pkgbase = harfbuzz-git
sha256sums = SKIP
pkgname = harfbuzz-git
+ depends = glib2
+ depends = freetype2
+ depends = graphite
+ optdepends = cairo: hb-view program
pkgname = harfbuzz-icu-git
+ pkgdesc = OpenType text shaping engine (git version) (ICU integration)
+ depends = harfbuzz
+ depends = icu
diff --git a/PKGBUILD b/PKGBUILD
index 9cea5ea5dafc..8d6e27b735cc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -43,7 +43,7 @@ check() {
PATH="$srcdir/path:$PATH" make -k check || :
}
-package_harfbuzz_git() {
+package_harfbuzz-git() {
depends=(glib2 freetype2 graphite)
optdepends=('cairo: hb-view program')
@@ -51,14 +51,14 @@ package_harfbuzz_git() {
make DESTDIR="$pkgdir" install
install -Dm644 COPYING "$pkgdir/usr/share/licenses/harfbuzz/COPYING"
-# Split harfbuzz-icu
+ # Split harfbuzz-icu
mkdir -p ../hb-icu/usr/{include/harfbuzz,lib/pkgconfig}; cd ../hb-icu
mv "$pkgdir"/usr/lib/libharfbuzz-icu* ./usr/lib
mv "$pkgdir"/usr/lib/pkgconfig/harfbuzz-icu.pc ./usr/lib/pkgconfig
mv "$pkgdir"/usr/include/harfbuzz/hb-icu.h ./usr/include/harfbuzz
}
-package_harfbuzz-icu_git(){
+package_harfbuzz-icu-git(){
pkgdesc="$pkgdesc (ICU integration)"
depends=(harfbuzz icu)