summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Rabert2018-05-14 15:53:48 -0400
committerAndrew Rabert2018-05-14 15:53:48 -0400
commitf44892ab19a48e5580fea2d927cdfb7026d857bd (patch)
tree1e96f884c4e3fd6fb710576b70bb107f35fafcc5
downloadaur-f44892ab19a48e5580fea2d927cdfb7026d857bd.tar.gz
init
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD23
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c5ad352097fa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = harmonize
+ pkgdesc = Create and synchronize transcoded copies of audio folders.
+ pkgver = 0.1.2
+ pkgrel = 1
+ url = https://github.com/nvllsvm/harmonize
+ arch = any
+ license = APACHE
+ makedepends = python-setuptools
+ depends = ffmpeg
+ depends = flac
+ depends = python
+ source = https://files.pythonhosted.org/packages/23/19/c19bcbcfa3c24f9069899c4e142c8f8c9fb874832102d5d97e7545896c69/harmonize-0.1.2.tar.gz
+ sha256sums = d7dea0a7b1f832088568248486b465fa64c52a48fb81d90216df5e393aae7727
+
+pkgname = harmonize
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..63699421737a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Contributor: Andrew Rabert <ar nullsum.net>
+
+pkgname=harmonize
+pkgver=0.1.2
+pkgrel=1
+pkgdesc="Create and synchronize transcoded copies of audio folders."
+url="https://github.com/nvllsvm/harmonize"
+depends=('ffmpeg' 'flac' 'python')
+makedepends=('python-setuptools')
+license=('APACHE')
+arch=('any')
+source=("https://files.pythonhosted.org/packages/23/19/c19bcbcfa3c24f9069899c4e142c8f8c9fb874832102d5d97e7545896c69/harmonize-0.1.2.tar.gz")
+sha256sums=('d7dea0a7b1f832088568248486b465fa64c52a48fb81d90216df5e393aae7727')
+
+build() {
+ cd harmonize-$pkgver
+ python setup.py build
+}
+
+package() {
+ cd harmonize-$pkgver
+ python setup.py install --root="$pkgdir" --optimize=1
+}