summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMerlin Sievers2024-03-08 13:44:03 +0100
committerMerlin Sievers2024-03-08 13:44:03 +0100
commitee4f6e3d9da634f8bace3c91d265bb66462cfb8c (patch)
treea235868b65106bdd73ccc076572dc304ff947758
parentff37923c31ba8609695e28bfb0fdeb7a96dea021 (diff)
downloadaur-ee4f6e3d9da634f8bace3c91d265bb66462cfb8c.tar.gz
Fix wrong usage of pkgname
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index de636e9d1e13..3ec3bf675e15 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Merlin Sievers <merlin here-a-dot sievers now-an-at posteo.net>
pkgname=harmony-music-git
pkgver=r581.0754ede
-pkgrel=1
+pkgrel=2
pkgdesc="A cross platform App for streaming Music"
arch=("x86_64")
url="https://github.com/anandnet/Harmony-Music"
@@ -28,30 +28,30 @@ source=(
sha256sums=('SKIP' 'SKIP' 'c3f34067478902a07fa334e3eac2e719d1f26b292318d1a8f5a40e63884c0402')
pkgver() {
- cd "${srcdir}/${pkgname%-git}"
+ cd "${srcdir}/Harmony-Music"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
prepare() {
- cd "${srcdir}/${pkgname%-git}"
+ cd "${srcdir}/Harmony-Music"
git submodule init
git config submodule.libs/flutter.url "${srcdir}/flutter"
git -c protocol.file.allow=always submodule update
}
build() {
- cd "${srcdir}/${pkgname%-git}"
+ cd "${srcdir}/Harmony-Music"
.flutter/bin/flutter build linux
}
package() {
- cd "${srcdir}/${pkgname%-git}/build/linux/x64/release/bundle"
+ cd "${srcdir}/Harmony-Music/build/linux/x64/release/bundle"
# Install the application bundle to /opt/harmonymusic
install -dm755 "${pkgdir}/opt/harmonymusic"
ln -s /usr/lib/libayatana-appindicator3.so lib/libindicator3.so
cp -a * "${pkgdir}/opt/harmonymusic/"
- cp -a "${srcdir}/${pkgname%-git}/LICENSE" "${pkgdir}/opt/harmonymusic/"
+ cp -a "${srcdir}/Harmony-Music/LICENSE" "${pkgdir}/opt/harmonymusic/"
install -Dm755 "${srcdir}/harmonymusic" "${pkgdir}/usr/bin/harmonymusic"
}