summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMerlin Sievers2024-03-06 20:00:41 +0100
committerMerlin Sievers2024-03-06 20:02:52 +0100
commitff37923c31ba8609695e28bfb0fdeb7a96dea021 (patch)
tree564f49c1795c214bb1437ad28eddee5a9f6546ca
downloadaur-ff37923c31ba8609695e28bfb0fdeb7a96dea021.tar.gz
Initial commit
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD57
-rwxr-xr-xharmonymusic3
3 files changed, 89 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2fa02899a09d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = harmony-music-git
+ pkgdesc = A cross platform App for streaming Music
+ pkgver = r581.0754ede
+ pkgrel = 1
+ url = https://github.com/anandnet/Harmony-Music
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = gtk3
+ depends = gdk-pixbuf2
+ depends = harfbuzz
+ depends = pango
+ depends = cairo
+ depends = zlib
+ depends = atk
+ depends = gcc-libs
+ depends = glibc
+ depends = glib2
+ depends = libayatana-appindicator
+ provides = harmony-music
+ conflicts = harmony-music
+ source = git+https://github.com/anandnet/Harmony-Music.git
+ source = git+https://github.com/flutter/flutter.git
+ source = harmonymusic
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = c3f34067478902a07fa334e3eac2e719d1f26b292318d1a8f5a40e63884c0402
+
+pkgname = harmony-music-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..de636e9d1e13
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,57 @@
+# Maintainer: Merlin Sievers <merlin here-a-dot sievers now-an-at posteo.net>
+pkgname=harmony-music-git
+pkgver=r581.0754ede
+pkgrel=1
+pkgdesc="A cross platform App for streaming Music"
+arch=("x86_64")
+url="https://github.com/anandnet/Harmony-Music"
+license=('GPL')
+makedepends=('git')
+depends=(
+ 'gtk3'
+ 'gdk-pixbuf2'
+ 'harfbuzz'
+ 'pango'
+ 'cairo'
+ 'zlib'
+ 'atk'
+ 'gcc-libs'
+ 'glibc'
+ 'glib2'
+ 'libayatana-appindicator')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=(
+ 'git+https://github.com/anandnet/Harmony-Music.git'
+ 'git+https://github.com/flutter/flutter.git'
+ 'harmonymusic')
+sha256sums=('SKIP' 'SKIP' 'c3f34067478902a07fa334e3eac2e719d1f26b292318d1a8f5a40e63884c0402')
+
+pkgver() {
+ cd "${srcdir}/${pkgname%-git}"
+
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "${srcdir}/${pkgname%-git}"
+ git submodule init
+ git config submodule.libs/flutter.url "${srcdir}/flutter"
+ git -c protocol.file.allow=always submodule update
+}
+
+build() {
+ cd "${srcdir}/${pkgname%-git}"
+ .flutter/bin/flutter build linux
+}
+
+package() {
+ cd "${srcdir}/${pkgname%-git}/build/linux/x64/release/bundle"
+ # Install the application bundle to /opt/harmonymusic
+ install -dm755 "${pkgdir}/opt/harmonymusic"
+ ln -s /usr/lib/libayatana-appindicator3.so lib/libindicator3.so
+ cp -a * "${pkgdir}/opt/harmonymusic/"
+ cp -a "${srcdir}/${pkgname%-git}/LICENSE" "${pkgdir}/opt/harmonymusic/"
+
+ install -Dm755 "${srcdir}/harmonymusic" "${pkgdir}/usr/bin/harmonymusic"
+}
diff --git a/harmonymusic b/harmonymusic
new file mode 100755
index 000000000000..c709938b8eaf
--- /dev/null
+++ b/harmonymusic
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+LD_LIBRARY_PATH="/opt/harmonymusic/lib:$LD_LIBRARY_PATH" /opt/harmonymusic/harmonymusic "$@"