summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Cholasta2013-11-01 12:04:50 +0100
committerJan Cholasta2013-11-01 12:04:50 +0100
commitbdf6046d5b18d61c29f6a1387fe4fc5d825cdab8 (patch)
treea8f3b3f6f2c589fdd093c2f978e418371396e27c
downloadaur-bdf6046d5b18d61c29f6a1387fe4fc5d825cdab8.tar.gz
Initial commit.
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD22
2 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7735d9937958
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = harmony-wad
+ pkgdesc = Harmony IWAD (game data)
+ pkgver = 1.1
+ pkgrel = 1
+ url = http://rabotik.nl/harmony.htm
+ arch = any
+ license = custom
+ source = http://files.drdteam.org/index.php/files/download/12950/harmony.zip
+ md5sums = 51b4b38e16622946edfd01d74d246120
+
+pkgname = harmony-wad
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..68ceed385f89
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Contributor: Jan Cholasta <grubber@grubber.cz>
+
+pkgname=harmony-wad
+pkgver=1.1
+pkgrel=1
+pkgdesc="Harmony IWAD (game data)"
+arch=('any')
+url="http://rabotik.nl/harmony.htm"
+license=('custom')
+source=(http://files.drdteam.org/index.php/files/download/12950/harmony.zip)
+md5sums=('51b4b38e16622946edfd01d74d246120')
+
+build() {
+ cd "$srcdir"
+
+ install -Dm644 harm1.wad "$pkgdir"/usr/share/games/harmony/harm1.wad
+ install -Dm644 Harmony.txt "$pkgdir"/usr/share/licenses/${pkgname}/Harmony.txt
+ install -Dm644 other-files/sounds.txt "$pkgdir"/usr/share/licenses/${pkgname}/sounds.txt
+
+ mkdir -p "$pkgdir"/usr/share/doom
+ ln -s /usr/share/games/harmony/harm1.wad "$pkgdir"/usr/share/doom/harm1.wad
+}