aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSarvasva (Savvy) Raghuvanshi2017-04-13 03:36:25 -0400
committerSarvasva (Savvy) Raghuvanshi2017-04-13 03:36:25 -0400
commite6d0d395c892c09b630c437117e1e3792a5ace58 (patch)
tree3ab0d66b9496848764bb65ebbd9fa63ca4cdee3a
downloadaur-e6d0d395c892c09b630c437117e1e3792a5ace58.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--LICENSE21
-rw-r--r--PKGBUILD25
-rw-r--r--README.md2
4 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8b785b7fe51d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = harvard-linux-printer
+ pkgdesc = Connect to Harvard University's printer network from an Arch Linux machine.
+ pkgver = 15.30afe11
+ pkgrel = 1
+ url = https://github.com/djsavvy/harvard-linux-printer
+ arch = any
+ license = MIT
+ makedepends = git
+ makedepends = coreutils
+ depends = cups
+ depends = samba
+ depends = smbclient
+ depends = bash
+ optdepends = gtk3-print-backends: to print from GTK3 applications
+ source = git://github.com/djsavvy/harvard-linux-printer#branch=aur-package
+ md5sums = SKIP
+
+pkgname = harvard-linux-printer
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..e041a00c09e8
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,21 @@
+MIT License
+
+Copyright (c) 2017 Sarvasva (Savvy) Raghuvanshi
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d44c398502dc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Savvy Raghuvanshi <sraghuvanshi at college dot harvard dot edu>
+
+pkgname=harvard-linux-printer
+pkgver=15.30afe11
+pkgrel=1
+pkgdesc="Connect to Harvard University's printer network from an Arch Linux machine."
+arch=('any')
+url="https://github.com/djsavvy/harvard-linux-printer"
+license=('MIT')
+depends=('cups' 'samba' 'smbclient' 'bash')
+makedepends=('git' 'coreutils')
+optdepends=('gtk3-print-backends: to print from GTK3 applications')
+source=("git://github.com/djsavvy/harvard-linux-printer#branch=aur-package")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ echo "$(git rev-list --count HEAD).$(git describe --always)" | sed -e 's/-/_/g'
+}
+
+
+package() {
+ cd "$pkgname"
+ install -Dm755 "$pkgname.sh" "$pkgdir/usr/bin/$pkgname"
+}
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..fe0505ecef28
--- /dev/null
+++ b/README.md
@@ -0,0 +1,2 @@
+# harvard-linux-printer
+A script to allow Harvard Linux users to connect to the FAS printer system.