summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbtd13372018-10-21 22:06:15 -0300
committerbtd13372018-10-21 22:06:15 -0300
commit55a2a5c2a615bdb6c8f3c961e8b19de511ea5b95 (patch)
tree0343a3e2663bc8e76ca6cfc7215439969e877cb7
downloadaur-55a2a5c2a615bdb6c8f3c961e8b19de511ea5b95.tar.gz
initial release
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD39
3 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a1436f279892
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = harvey-git
+ pkgdesc = Harvey is a color contrast checker. It checks a given set of colors for WCAG contrast compliance. Designed for Pantheon Shell
+ pkgver = latest
+ pkgrel = 1
+ url = https://github.com/danrabbit/harvey
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = meson
+ makedepends = ninja
+ depends = gtk3
+ depends = vala
+ depends = granite
+ optdepends = lib32-json-glib
+ provides = harvey
+ conflicts = harvey
+ source = git+https://github.com/danrabbit/harvey.git
+ md5sums = SKIP
+
+pkgname = harvey-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b25c15b81fae
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*~
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..be5cca0b5f25
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Helder Bertoldo <helder.bertoldo@gmail.com>
+# Contributor:
+
+_gitname=harvey
+_author=danrabbit
+pkgname=("${_gitname}-git")
+pkgver=latest
+pkgrel=1
+pkgdesc="Harvey is a color contrast checker. It checks a given set of colors for WCAG contrast compliance. Designed for Pantheon Shell"
+arch=('i686' 'x86_64')
+url="https://github.com/${_author}/${_gitname}"
+license=('GPL3')
+depends=('gtk3' 'vala' 'granite')
+optdepends=('lib32-json-glib')
+makedepends=('git' 'meson' 'ninja')
+provides=("${_gitname}")
+conflicts=("${_gitname}")
+source=("git+${url}.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${_gitname}"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+build() {
+ cd "${_gitname}/"
+ meson . _build --prefix=/usr
+ ninja -C _build
+}
+
+package() {
+ cd "${_gitname}/"
+ DESTDIR="${pkgdir}" ninja -C _build install
+}
+