summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSteffen Weber2016-01-27 00:17:19 +0100
committerSteffen Weber2016-01-27 00:17:19 +0100
commit050bac9c2ead25fa326e94c47b2be70dbc3e022f (patch)
treea9e73dacefd8e2a2e3bedeaa881b9f69b8e8f9ed
parent0afd9424152ac3f1e04573aaea70e3e7801a4c40 (diff)
downloadaur-050bac9c2ead25fa326e94c47b2be70dbc3e022f.tar.gz
Update to 1.3
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD30
2 files changed, 24 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1bf66f9d3d84..4928335008b1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,18 @@
+# Generated by mksrcinfo v8
+# Tue Jan 26 23:16:48 UTC 2016
pkgbase = hasciicam
- pkgdesc = Renders video input as ascii (either to the terminal, to a text file, or a live webpage)
- pkgver = 1.1.2
+ pkgdesc = Renders video input as ascii (to the terminal, textfile, or live webpage)
+ pkgver = 1.3
pkgrel = 1
url = http://ascii.dyne.org/
install = hasciicam.install
arch = i686
arch = x86_64
- license = GPL
+ license = GPL3
depends = aalib
depends = libv4l
- depends = ftplib
- source = https://files.dyne.org/.xsend.php?file=hasciicam/releases/hasciicam_1.1.2.tar.gz
- md5sums = 2c7393270e18ab913043683fa3390d8c
+ source = https://files.dyne.org/hasciicam/hasciicam_1.3.tar.gz
+ md5sums = 4d77c6a4cf6e2b1474d5fec0ff450b80
pkgname = hasciicam
diff --git a/PKGBUILD b/PKGBUILD
index c189994bea48..83e2ab6abfce 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,30 @@
+# Maintainer: Steffen Weber <-boenki-gmx-de->
# Contributor: schuay <jakob.gruber@gmail.com>
# Contributor: rennero <rennero@bastardi.net>
+
pkgname=hasciicam
-pkgver=1.1.2
+pkgver=1.3
pkgrel=1
-pkgdesc="Renders video input as ascii (either to the terminal, to a text file, or a live webpage)"
+pkgdesc="Renders video input as ascii (to the terminal, textfile, or live webpage)"
url="http://ascii.dyne.org/"
-depends=('aalib' 'libv4l' 'ftplib')
+depends=('aalib' 'libv4l')
arch=('i686' 'x86_64')
-install=${pkgname}.install
-source=("https://files.dyne.org/.xsend.php?file=hasciicam/releases/${pkgname}_$pkgver.tar.gz")
-md5sums=('2c7393270e18ab913043683fa3390d8c')
-license=('GPL')
+install=$pkgname.install
+source=("https://files.dyne.org/$pkgname/${pkgname}_$pkgver.tar.gz")
+md5sums=('4d77c6a4cf6e2b1474d5fec0ff450b80')
+license=('GPL3')
build() {
- cd "${srcdir}"/${pkgname}-$pkgver
-
- sed -i 's_\(Iconsdir.*\)icons$_\1pixmaps_; /Menu_DATA/d' share/Makefile.am
- ./configure --prefix="${pkgdir}"/usr --mandir="${pkgdir}"/usr/share/man
-
+ cd ${pkgname}_$pkgver
+ ./configure --prefix="$pkgdir/usr" --mandir="$pkgdir/usr/share/man"
make
}
+
package() {
- cd "${srcdir}"/${pkgname}-$pkgver
+ cd ${pkgname}_$pkgver
make install
+
+ cd "$pkgdir/usr/share"
+ mv icons pixmaps
+ rm -r menu
}