summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakob Gruber2015-06-21 23:22:48 +0200
committerJakob Gruber2015-06-21 23:24:56 +0200
commit0afd9424152ac3f1e04573aaea70e3e7801a4c40 (patch)
treead50817e0f95796245dd21b436298a9b43e52aac
downloadaur-0afd9424152ac3f1e04573aaea70e3e7801a4c40.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD26
-rw-r--r--hasciicam.install11
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1bf66f9d3d84
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = hasciicam
+ pkgdesc = Renders video input as ascii (either to the terminal, to a text file, or a live webpage)
+ pkgver = 1.1.2
+ pkgrel = 1
+ url = http://ascii.dyne.org/
+ install = hasciicam.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = aalib
+ depends = libv4l
+ depends = ftplib
+ source = https://files.dyne.org/.xsend.php?file=hasciicam/releases/hasciicam_1.1.2.tar.gz
+ md5sums = 2c7393270e18ab913043683fa3390d8c
+
+pkgname = hasciicam
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c189994bea48
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Contributor: schuay <jakob.gruber@gmail.com>
+# Contributor: rennero <rennero@bastardi.net>
+pkgname=hasciicam
+pkgver=1.1.2
+pkgrel=1
+pkgdesc="Renders video input as ascii (either to the terminal, to a text file, or a live webpage)"
+url="http://ascii.dyne.org/"
+depends=('aalib' 'libv4l' 'ftplib')
+arch=('i686' 'x86_64')
+install=${pkgname}.install
+source=("https://files.dyne.org/.xsend.php?file=hasciicam/releases/${pkgname}_$pkgver.tar.gz")
+md5sums=('2c7393270e18ab913043683fa3390d8c')
+license=('GPL')
+
+build() {
+ cd "${srcdir}"/${pkgname}-$pkgver
+
+ sed -i 's_\(Iconsdir.*\)icons$_\1pixmaps_; /Menu_DATA/d' share/Makefile.am
+ ./configure --prefix="${pkgdir}"/usr --mandir="${pkgdir}"/usr/share/man
+
+ make
+}
+package() {
+ cd "${srcdir}"/${pkgname}-$pkgver
+ make install
+}
diff --git a/hasciicam.install b/hasciicam.install
new file mode 100644
index 000000000000..60b6275490ab
--- /dev/null
+++ b/hasciicam.install
@@ -0,0 +1,11 @@
+post_install() {
+ [ -x /usr/bin/update-desktop-database ] && update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}