summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorColin Wallace2016-02-20 20:50:25 -0800
committerColin Wallace2016-02-20 20:50:25 -0800
commitc02cf682b643ec0ee32c0110309017b8ea57977c (patch)
tree9d0722b582fb066ad18f99127359c1d5998873a0
parent68f1270ed88d8f7d87d96c70d492ac762b356dec (diff)
downloadaur-c02cf682b643ec0ee32c0110309017b8ea57977c.tar.gz
Patch the path to the data directory
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
-rw-r--r--share-dir.patch11
3 files changed, 18 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 40d8dec81531..3f7b2b219f0d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Sun Feb 21 03:27:54 UTC 2016
+# Sun Feb 21 04:50:03 UTC 2016
pkgbase = hase-git
pkgdesc = Gravity artillery shooter game
pkgver = 341.da32fd2
@@ -16,8 +16,10 @@ pkgbase = hase-git
provides = hase
source = git+https://github.com/theZiz/hase.git
source = sparrow-dyn.patch
+ source = share-dir.patch
md5sums = SKIP
md5sums = f71a4a3fb0569eaf3d66c818b1f8470c
+ md5sums = bf589b325d503d7b32037b607db65ff1
pkgname = hase-git
diff --git a/PKGBUILD b/PKGBUILD
index d9096711dc8e..e14686cbf695 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,8 +10,8 @@ license=('GPL')
depends=('sdl' 'sdl_image' 'sdl_mixer' 'sdl_net' 'sparrow3d')
makedepends=('git')
provides=('hase')
-source=("git+https://github.com/theZiz/hase.git" "sparrow-dyn.patch")
-md5sums=('SKIP' 'f71a4a3fb0569eaf3d66c818b1f8470c')
+source=("git+https://github.com/theZiz/hase.git" "sparrow-dyn.patch" "share-dir.patch")
+md5sums=('SKIP' 'f71a4a3fb0569eaf3d66c818b1f8470c' 'bf589b325d503d7b32037b607db65ff1')
pkgver() {
cd "$srcdir"/hase
@@ -22,6 +22,8 @@ prepare() {
cd "$srcdir"/hase
# Patch hase to link against sparrow dynamically
patch -p1 -i "$srcdir"/sparrow-dyn.patch Makefile
+ # Patch so data directory is /usr/share/hase, instead of virtualenv directory
+ patch -p1 -i "$srcdir"/share-dir.patch install.sh
}
build() {
diff --git a/share-dir.patch b/share-dir.patch
new file mode 100644
index 000000000000..b10eeb7550dc
--- /dev/null
+++ b/share-dir.patch
@@ -0,0 +1,11 @@
+--- install.sh 2016-02-20 20:43:06.656969785 -0800
++++ install.sh.new 2016-02-20 20:45:30.987122334 -0800
+@@ -2,7 +2,7 @@
+ if [ $# -gt 0 ]
+ then
+ make clean
+- make PARAMETER="-DDATA_FOLDER=\"\\\"$1/share/hase\\\"\"" NO_DEBUG=1
++ make PARAMETER="-DDATA_FOLDER=\"\\\"/usr/share/hase\\\"\"" NO_DEBUG=1
+ cp hase "$1/bin"
+ if [ ! -d "$1/share/hase" ]; then mkdir "$1/share/hase";fi
+ cp -r data "$1/share/hase"