summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle Keen2015-06-13 00:17:54 -0400
committerKyle Keen2015-06-13 00:17:54 -0400
commitc9a944189ded860220098c8df5e43bc191bef850 (patch)
tree82c1b908be4a296e5f2068e0d185087b3ce87d4c
downloadaur-c9a944189ded860220098c8df5e43bc191bef850.tar.gz
Initial import
-rw-r--r--.AURINFO14
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD39
3 files changed, 68 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..65c3d2c42dce
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,14 @@
+pkgbase = haserl
+ pkgdesc = Tiny dynamic CGI web server with your shell or Lua.
+ pkgver = 0.9.33
+ pkgrel = 1
+ url = http://haserl.sourceforge.net
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ depends = sh
+ depends = lua
+ source = http://downloads.sourceforge.net/haserl/haserl-0.9.33.tar.gz
+
+pkgname = haserl
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0cb494ed5800
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = haserl
+ pkgdesc = Tiny dynamic CGI web server with your shell or Lua.
+ pkgver = 0.9.33
+ pkgrel = 1
+ url = http://haserl.sourceforge.net
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ depends = sh
+ depends = lua
+ source = http://downloads.sourceforge.net/haserl/haserl-0.9.33.tar.gz
+ md5sums = a9decddb508944d56f71dd2f821e2ec5
+
+pkgname = haserl
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6a95e47e00ac
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Kyle Keen <keenerd@gmail.com>
+pkgname=haserl
+pkgver=0.9.33
+pkgrel=1
+pkgdesc="Tiny dynamic CGI web server with your shell or Lua."
+arch=('i686' 'x86_64')
+url="http://haserl.sourceforge.net"
+_watch="http://sourceforge.net/projects/haserl/files/"
+license=('GPL2')
+depends=('sh' 'lua')
+source=(http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz)
+md5sums=('a9decddb508944d56f71dd2f821e2ec5')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ # lua51 also supported, see INSTALL
+ ./configure prefix="$pkgdir/usr" --enable-luashell --enable-luacshell --disable-bashshell --disable-bash-extensions --with-lua
+ make
+ mv src/haserl haserl-lua
+
+ ./configure prefix="$pkgdir/usr" --disable-luashell --disable-luacshell --enable-bashshell --enable-bash-extensions --without-lua
+ make
+ mv src/haserl haserl-sh
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ # make install is not friendly to installing both
+ install -d "$pkgdir/usr/bin"
+ install -d "$pkgdir/usr/share/man/man1"
+ install -Dm644 doc/haserl.1 "$pkgdir/usr/share/man/man1/"
+
+ install -Dm755 haserl-lua "$pkgdir/usr/bin/haserl-lua"
+ install -Dm755 haserl-sh "$pkgdir/usr/bin/haserl-sh"
+
+ ln -s "/usr/bin/haserl-sh" "$pkgdir/usr/bin/haserl"
+}
+
+