summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoranthraxx2016-09-21 16:55:42 +0200
committeranthraxx2016-09-21 16:55:42 +0200
commit91fa213f3d0b052ab277d591c8139432ed300f94 (patch)
tree622fe7ed79affa0f06550fc0f7940d866f5146bf
parent5f93c6f78262cee443709bd4418cba6d8d37196b (diff)
downloadaur-91fa213f3d0b052ab277d591c8139432ed300f94.tar.gz
upgpkg: hash-identifier 1.1-4 (switched upstream url)
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
2 files changed, 8 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 20c31af4f127..4787aed86bd0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,12 @@
-# Generated by mksrcinfo v8
-# Wed Feb 17 17:44:19 UTC 2016
pkgbase = hash-identifier
pkgdesc = Identify the different types of hashes used to encrypt data and especially passwords
pkgver = 1.1
pkgrel = 4
- url = https://code.google.com/archive/p/hash-identifier/
+ url = https://github.com/Miserlou/Hash-Identifier
arch = any
license = GPL3
depends = python2
- source = https://hash-identifier.googlecode.com/files/Hash_ID_v1.1.py
+ source = https://raw.githubusercontent.com/Miserlou/Hash-Identifier/70f3da48079607bd5d106c4b9767fe4abf14150e/Hash_ID.py
sha512sums = af889ebd84d2bd73c9a9623b5573bbb8a4cf5d3ffa6de75b272644905c4c1fa7e5bfcfb24d5ac75ffd73e4305447dd357f16b6248a16424094fc8b8cffca378d
pkgname = hash-identifier
diff --git a/PKGBUILD b/PKGBUILD
index 2c9bbfa3b08a..23f5a1fc0a24 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,21 +4,22 @@
pkgname=hash-identifier
pkgver=1.1
pkgrel=4
+_githash=70f3da48079607bd5d106c4b9767fe4abf14150e
pkgdesc='Identify the different types of hashes used to encrypt data and especially passwords'
-url='https://code.google.com/archive/p/hash-identifier/'
+url='https://github.com/Miserlou/Hash-Identifier'
arch=('any')
license=('GPL3')
depends=('python2')
-source=(https://hash-identifier.googlecode.com/files/Hash_ID_v${pkgver}.py)
+source=(https://raw.githubusercontent.com/Miserlou/Hash-Identifier/${_githash}/Hash_ID.py)
sha512sums=('af889ebd84d2bd73c9a9623b5573bbb8a4cf5d3ffa6de75b272644905c4c1fa7e5bfcfb24d5ac75ffd73e4305447dd357f16b6248a16424094fc8b8cffca378d')
prepare() {
- sed -e "s|env python|env python2|" -i Hash_ID_v${pkgver}.py
- sed -e 's|\r||g' -i Hash_ID_v${pkgver}.py
+ sed -e "s|env python|env python2|" -i Hash_ID.py
+ sed -e 's|\r||g' -i Hash_ID.py
}
package() {
- install -Dm 755 Hash_ID_v${pkgver}.py "${pkgdir}/usr/bin/hash-identifier"
+ install -Dm 755 Hash_ID.py "${pkgdir}/usr/bin/hash-identifier"
}
# vim: ts=2 sw=2 et: