summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author05storm262015-12-06 17:52:11 +0100
committer05storm262015-12-06 18:05:31 +0100
commit0394c53725d44acbc399a6506a370381557b6b9e (patch)
tree6390026465c2cc07c1e7b5744d5c0bcd273675d0
downloadaur-0394c53725d44acbc399a6506a370381557b6b9e.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD61
2 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f2020584fc63
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Sun Dec 6 16:56:22 UTC 2015
+pkgbase = hashcat-utils-git
+ pkgdesc = Hashcat-utils are a set of small utilities that are useful in advanced password cracking.
+ pkgver = 1.2.r1.g9135127
+ pkgrel = 1
+ url = https://github.com/hashcat/hashcat-utils
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = make
+ provides = hashcat-utils
+ source = git://github.com/hashcat/hashcat-utils.git
+ md5sums = SKIP
+
+pkgname = hashcat-utils-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..52103eb1a681
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,61 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# See http://wiki.archlinux.org/index.php/VCS_PKGBUILD_Guidelines
+# for more information on packaging from GIT sources.
+
+# Maintainer: Your Name <youremail@domain.com>
+pkgname=hashcat-utils-git
+pkgver=1.2.r1.g9135127
+pkgrel=1
+pkgdesc="Hashcat-utils are a set of small utilities that are useful in advanced password cracking."
+arch=('i686' 'x86_64')
+url="https://github.com/hashcat/hashcat-utils"
+license=('MIT')
+groups=()
+depends=()
+makedepends=('git' 'make')
+provides=('hashcat-utils')
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+source=(git://github.com/hashcat/hashcat-utils.git)
+noextract=()
+md5sums=('SKIP')
+
+_gitroot='https://github.com/hashcat/hashcat-utils.git'
+_gitname='hashcat-utils'
+
+pkgver() {
+ cd "$srcdir/$_gitname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir/$_gitname/src"
+
+ make linux
+}
+
+package() {
+ cd "$srcdir/$_gitname/src"
+
+ install -D -m644 ../LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ mkdir -p "$pkgdir/bin/"
+
+ cp ./*.bin "$pkgdir/bin/"
+
+ cd "$pkgdir/bin/"
+ for i in $(ls ".")
+ do
+ chmod +x $i
+ mv $i ${i%.*}
+ done
+
+}
+
+# vim:set ts=2 sw=2 et: