summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author05storm262015-12-10 14:51:07 +0100
committer05storm262015-12-10 14:51:07 +0100
commit952e7767ba543ee92c4a9a8a5a65432bdb86869f (patch)
treebaa6d8422cf1764a5edead023a07bbbb885a7ef0
parent75cecc76ffd10fe3e4522db5c81e3209a92bd774 (diff)
downloadaur-952e7767ba543ee92c4a9a8a5a65432bdb86869f.tar.gz
Install the perl scripts too. Add conflict for the non-git version.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD25
2 files changed, 17 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f2020584fc63..7b02a15e0f89 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,18 @@
# Generated by mksrcinfo v8
-# Sun Dec 6 16:56:22 UTC 2015
+# Thu Dec 10 13:50:15 UTC 2015
pkgbase = hashcat-utils-git
pkgdesc = Hashcat-utils are a set of small utilities that are useful in advanced password cracking.
pkgver = 1.2.r1.g9135127
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/hashcat/hashcat-utils
arch = i686
arch = x86_64
license = MIT
makedepends = git
makedepends = make
+ depends = perl
provides = hashcat-utils
+ conflicts = hashcat-utils
source = git://github.com/hashcat/hashcat-utils.git
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 8bca6d3f2b31..6dd270558924 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,15 @@
-# This is an example PKGBUILD file. Use this as a start to creating your own,
-# and remove these comments. For more information, see 'man PKGBUILD'.
-# NOTE: Please fill out the license field for your package! If it is unknown,
-# then please put 'unknown'.
-
-# See http://wiki.archlinux.org/index.php/VCS_PKGBUILD_Guidelines
-# for more information on packaging from GIT sources.
-
-# Maintainer: Your Name <youremail@domain.com>
pkgname=hashcat-utils-git
pkgver=1.2.r1.g9135127
-pkgrel=1
+pkgrel=2
pkgdesc="Hashcat-utils are a set of small utilities that are useful in advanced password cracking."
arch=('i686' 'x86_64')
url="https://github.com/hashcat/hashcat-utils"
license=('MIT')
groups=()
-depends=()
+depends=('perl')
makedepends=('git' 'make')
provides=('hashcat-utils')
-conflicts=()
+conflicts=('hashcat-utils')
replaces=()
backup=()
options=()
@@ -39,6 +30,7 @@ build() {
cd "$srcdir/$_gitname/src"
make linux
+ strip *.bin
}
package() {
@@ -56,6 +48,15 @@ package() {
mv $i ${i%.*}
done
+ cd "$srcdir/$_gitname/src"
+
+ cp ./*.pl "$pkgdir/usr/bin"
+
+ for i in $(ls "." | grep -E "\.pl$")
+ do
+ chmod +x $i
+ done
+
}
# vim:set ts=2 sw=2 et: