summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDennis Boerm2015-06-08 20:49:51 +0200
committerDennis Boerm2015-06-08 20:49:51 +0200
commitf2c0bfe1faf418a86e488636a0bdb1826d818702 (patch)
tree4b8cd12111d88a7eb42568634082111fc896e462
downloadaur-f2c0bfe1faf418a86e488636a0bdb1826d818702.tar.gz
initial
-rw-r--r--.SRCINFO17
-rw-r--r--Makefile.patch37
-rw-r--r--PKGBUILD37
3 files changed, 91 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..32189c81f988
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by makepkg 4.2.1
+# Thu Mar 12 09:10:57 UTC 2015
+pkgbase = hashlibpp
+ pkgdesc = Hashing library
+ pkgver = 0.3.4
+ pkgrel = 2
+ url = http://sourceforge.net/projects/hashlib2plus/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ source = http://downloads.sourceforge.net/project/hashlib2plus/0.3.4/hashlibpp_0_3_4.zip
+ source = Makefile.patch
+ md5sums = ea5643e92d261258ecefbb92e398c572
+ md5sums = 1d62e5ea8125d8a9ff054114956e2851
+
+pkgname = hashlibpp
+
diff --git a/Makefile.patch b/Makefile.patch
new file mode 100644
index 000000000000..307799eae4c8
--- /dev/null
+++ b/Makefile.patch
@@ -0,0 +1,37 @@
+*** Makefile 2008-02-10 12:13:18.000000000 +0100
+--- Makefile.new 2009-06-25 19:24:43.000000000 +0200
+***************
+*** 47,62 ****
+ # Edit the following lines to meet your needs
+
+ # Path to install the headerfiles
+! INCLUDE_PATH = /usr/include/hashlib++
+
+ # Path to install the library
+! LIB_PATH = /usr/local/lib/
+
+ # Compiler to use
+ COMPILER = g++
+
+ # Global options for the compiler
+! COPTIONS = -ansi -Wall -Wextra
+
+ #-----------------------------------------------------------------------
+ # DON'T CHANGE ANYTHING BELOW
+--- 47,62 ----
+ # Edit the following lines to meet your needs
+
+ # Path to install the headerfiles
+! INCLUDE_PATH = $(DESTDIR)/usr/include/hashlib++
+
+ # Path to install the library
+! LIB_PATH = $(DESTDIR)/usr/lib/
+
+ # Compiler to use
+ COMPILER = g++
+
+ # Global options for the compiler
+! COPTIONS = -ansi -Wall -Wextra -fPIC
+
+ #-----------------------------------------------------------------------
+ # DON'T CHANGE ANYTHING BELOW
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..36493b57ac25
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: allspark <allspark at cyb0rg dot org>
+
+pkgname=hashlibpp
+pkgver=0.3.4
+pkgrel=2
+pkgdesc="Hashing library"
+arch=('i686' 'x86_64')
+url="http://sourceforge.net/projects/hashlib2plus/"
+license=('GPL')
+groups=()
+depends=()
+makedepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+source=(http://downloads.sourceforge.net/project/hashlib2plus/$pkgver/hashlibpp_0_3_4.zip Makefile.patch)
+noextract=()
+md5sums=('ea5643e92d261258ecefbb92e398c572' '1d62e5ea8125d8a9ff054114956e2851')
+
+build() {
+ cd $srcdir/hashlib2plus/trunk/src
+ patch -p0 -i ../../../Makefile.patch || return 1
+
+ make -j1 || return 1
+}
+
+package() {
+ cd $srcdir/hashlib2plus/trunk/src
+ mkdir -p "$pkgdir"/usr/lib
+ mkdir -p "$pkgdir"/usr/include
+
+ make DESTDIR=$pkgdir install || return 1
+}