summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCorey Powell2023-07-10 14:34:59 -0500
committerCorey Powell2023-07-10 14:34:59 -0500
commite905d46779adb4c95c6d114f0b77fbb4cb96c0db (patch)
tree2e38760fefed74125c457a95ce48b270bfcb0b1b
parentbc431db12ca287a76ed198a39b4146b324628711 (diff)
downloadaur-e905d46779adb4c95c6d114f0b77fbb4cb96c0db.tar.gz
Apply patch to Makefile to allow compiling against mbedtls2
Thanks to Apprentice-Alchemist on github
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD14
-rw-r--r--mbedtls2-Makefile.patch12
3 files changed, 27 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2186d8d186ba..58f20afb60cf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = hashlink
pkgdesc = A virtual machine for Haxe (tagged releases)
pkgver = 1.13
- pkgrel = 2
+ pkgrel = 3
url = https://hashlink.haxe.org/
arch = x86_64
license = MIT
@@ -10,11 +10,13 @@ pkgbase = hashlink
depends = libvorbis
depends = openal
depends = sdl2
- depends = mbedtls
+ depends = mbedtls2
depends = libuv
depends = glu
conflicts = hashlink-git
source = https://github.com/HaxeFoundation/hashlink/archive/1.13.tar.gz
- md5sums = d2b6df0c10dd26977c1bceaf1eca7d58
+ source = mbedtls2-Makefile.patch
+ sha256sums = 696aef6871771e5e12c617df79187d1761e79bcfe3927531e99f665a8002956f
+ sha256sums = 3d272e39333fbf0cbe17667f608a7616a3eef543fb574e1e9b51460f8b5f3db0
pkgname = hashlink
diff --git a/PKGBUILD b/PKGBUILD
index 563b81fad4ed..ecd36cb0e1ed 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# So if you want official releases, this is the PKGBUILD for you.
pkgname=hashlink
pkgver=1.13
-pkgrel=2
+pkgrel=3
pkgdesc="A virtual machine for Haxe (tagged releases)"
url="https://hashlink.haxe.org/"
arch=(x86_64)
@@ -16,12 +16,18 @@ depends=(
'libvorbis'
'openal'
'sdl2'
- 'mbedtls'
+ 'mbedtls2'
'libuv'
'glu'
)
-source=("https://github.com/HaxeFoundation/hashlink/archive/${pkgver}.tar.gz")
-md5sums=('d2b6df0c10dd26977c1bceaf1eca7d58')
+source=("https://github.com/HaxeFoundation/hashlink/archive/${pkgver}.tar.gz"
+ "mbedtls2-Makefile.patch")
+sha256sums=('696aef6871771e5e12c617df79187d1761e79bcfe3927531e99f665a8002956f'
+ '3d272e39333fbf0cbe17667f608a7616a3eef543fb574e1e9b51460f8b5f3db0')
+
+prepare() {
+ patch "$srcdir/${pkgname}-${pkgver}/Makefile" -i ./mbedtls2-Makefile.patch
+}
build() {
cd "$srcdir/${pkgname}-${pkgver}"
diff --git a/mbedtls2-Makefile.patch b/mbedtls2-Makefile.patch
new file mode 100644
index 000000000000..e33fe03dc752
--- /dev/null
+++ b/mbedtls2-Makefile.patch
@@ -0,0 +1,12 @@
+--- Makefile 2023-07-10 13:59:46.357865743 -0500
++++ Makefile.new 2023-07-10 13:59:32.367866662 -0500
+@@ -115,6 +115,9 @@
+ LIBFLAGS += -L/opt/libjpeg-turbo/lib64
+ endif
+
++CFLAGS += -I/usr/include/mbedtls2
++LIBFLAGS += -L/usr/lib/mbedtls2
++
+ LIBOPENAL = -lopenal
+ LIBOPENGL = -lGL
+ RELEASE_NAME = linux