summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy B2017-09-29 23:23:40 +0200
committerAndy B2017-09-29 23:23:40 +0200
commit074679338453059de3864dd4981eb0cf4871431b (patch)
treeb939ad1b797f1cff2d09e9953e5b481440a75161
parent7a2e0849bbb4b1b1f9909e4e60b39b89fb73e89f (diff)
downloadaur-074679338453059de3864dd4981eb0cf4871431b.tar.gz
haskell-alsa-mixer 0.2.0.3-4
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD18
-rw-r--r--haskell-alsa-mixer.install27
3 files changed, 12 insertions, 40 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 36acfab7048e..fb4843bdcc92 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,17 @@
pkgbase = haskell-alsa-mixer
pkgdesc = Provides bindings to the ALSA simple mixer API
pkgver = 0.2.0.3
- pkgrel = 3
+ pkgrel = 4
url = https://hackage.haskell.org/package/alsa-core
- install = haskell-alsa-mixer.install
arch = i686
arch = x86_64
license = BSD
+ makedepends = ghc
makedepends = c2hs
- depends = ghc
+ depends = ghc-libs
depends = haskell-alsa-core
depends = haskell-base
depends = haskell-unix
- options = staticlibs
source = https://hackage.haskell.org/packages/archive/alsa-mixer/0.2.0.3/alsa-mixer-0.2.0.3.tar.gz
sha256sums = f76deb4081a2ce4a765e78a017b2e13c073d2aaa5a2d2652fd5e635dd169cf8d
diff --git a/PKGBUILD b/PKGBUILD
index 06b253f40948..900360389f4d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,35 +3,35 @@
pkgname=haskell-alsa-mixer
_hkgname=alsa-mixer
pkgver=0.2.0.3
-pkgrel=3
+pkgrel=4
pkgdesc="Provides bindings to the ALSA simple mixer API"
url=https://hackage.haskell.org/package/alsa-core
license=('BSD')
arch=('i686' 'x86_64')
-depends=('ghc' 'haskell-alsa-core' 'haskell-base' 'haskell-unix')
-makedepends=('c2hs')
+depends=('ghc-libs' 'haskell-alsa-core' 'haskell-base' 'haskell-unix')
+makedepends=('ghc' 'c2hs')
source=("https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
sha256sums=('f76deb4081a2ce4a765e78a017b2e13c073d2aaa5a2d2652fd5e635dd169cf8d')
-install="${pkgname}.install"
-options=('staticlibs')
build() {
cd ${_hkgname}-${pkgver}
- runhaskell Setup configure -O --enable-shared --enable-executable-dynamic \
+ runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
--prefix=/usr --docdir="/usr/share/doc/${pkgname}" \
- --libsubdir=\$compiler/site-local/\$pkgid
+ --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid
runhaskell Setup build
runhaskell Setup haddock
runhaskell Setup register --gen-script
runhaskell Setup unregister --gen-script
+ sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
}
package() {
cd ${_hkgname}-${pkgver}
- install -D -m744 register.sh "${pkgdir}/usr/share/haskell/${pkgname}/register.sh"
- install -m744 unregister.sh "${pkgdir}/usr/share/haskell/${pkgname}/unregister.sh"
+ install -D -m744 register.sh "${pkgdir}/usr/share/haskell/register/${pkgname}.sh"
+ install -D -m744 unregister.sh "${pkgdir}/usr/share/haskell/unregister/${pkgname}.sh"
+
install -d -m755 "${pkgdir}/usr/share/doc/ghc/html/libraries"
ln -s /usr/share/doc/${pkgname}/html "${pkgdir}/usr/share/doc/ghc/html/libraries/${_hkgname}"
runhaskell Setup copy --destdir="${pkgdir}"
diff --git a/haskell-alsa-mixer.install b/haskell-alsa-mixer.install
deleted file mode 100644
index 3392eccbd3c3..000000000000
--- a/haskell-alsa-mixer.install
+++ /dev/null
@@ -1,27 +0,0 @@
-# custom variables
-pkgname=haskell-alsa-mixer
-HS_DIR=/usr/share/haskell/${pkgname}
-
-# functions
-post_install() {
- ${HS_DIR}/register.sh
- (cd /usr/share/doc/ghc/html/libraries; ./gen_contents_index)
-}
-
-pre_upgrade() {
- ${HS_DIR}/unregister.sh
-}
-
-post_upgrade() {
- ${HS_DIR}/register.sh
- (cd /usr/share/doc/ghc/html/libraries; ./gen_contents_index)
-}
-
-pre_remove() {
- ${HS_DIR}/unregister.sh
-}
-
-post_remove() {
- (cd /usr/share/doc/ghc/html/libraries; ./gen_contents_index)
-}
-