summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy B2016-04-06 21:54:20 +0200
committerAndy B2016-04-06 22:01:47 +0200
commit92ae7dfe3e664a7396129e6606bb46726d7cd725 (patch)
tree30b7cc65350635250330ccd72cd3482891b44ca1
downloadaur-92ae7dfe3e664a7396129e6606bb46726d7cd725.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD41
-rw-r--r--haskell-alsa-mixer.install27
3 files changed, 87 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b356917b29ad
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = haskell-alsa-mixer
+ pkgdesc = Provides bindings to the ALSA simple mixer API
+ pkgver = 0.2.0.3
+ pkgrel = 1
+ url = https://hackage.haskell.org/package/alsa-core
+ install = haskell-alsa-mixer.install
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = c2hs
+ depends = haskell-alsa-core
+ depends = haskell-base
+ depends = haskell-unix
+ options = staticlibs
+ source = https://hackage.haskell.org/packages/archive/alsa-mixer/0.2.0.3/alsa-mixer-0.2.0.3.tar.gz
+ sha256sums = f76deb4081a2ce4a765e78a017b2e13c073d2aaa5a2d2652fd5e635dd169cf8d
+
+pkgname = haskell-alsa-mixer
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eae2e6daaddd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Andy B. <brofi.archlinux at gmail dot com>
+
+pkgname=haskell-alsa-mixer
+_hkgname=alsa-mixer
+pkgver=0.2.0.3
+pkgrel=1
+pkgdesc="Provides bindings to the ALSA simple mixer API"
+url=https://hackage.haskell.org/package/alsa-core
+license=('BSD')
+arch=('i686' 'x86_64')
+depends=('haskell-alsa-core' 'haskell-base' 'haskell-unix')
+makedepends=('c2hs')
+source=("https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
+sha256sums=('f76deb4081a2ce4a765e78a017b2e13c073d2aaa5a2d2652fd5e635dd169cf8d')
+install="${pkgname}.install"
+options=('staticlibs')
+
+build() {
+ cd ${_hkgname}-${pkgver}
+
+ runhaskell Setup configure -O -p --enable-library-profiling --enable-shared \
+ --prefix=/usr --docdir="/usr/share/doc/${pkgname}" \
+ --libsubdir=\$compiler/site-local/\$pkgid
+ runhaskell Setup build
+ runhaskell Setup haddock
+ runhaskell Setup register --gen-script
+ runhaskell Setup unregister --gen-script
+ sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
+}
+
+package() {
+ cd ${_hkgname}-${pkgver}
+ install -D -m744 register.sh "${pkgdir}/usr/share/haskell/${pkgname}/register.sh"
+ install -m744 unregister.sh "${pkgdir}/usr/share/haskell/${pkgname}/unregister.sh"
+ install -d -m755 "${pkgdir}/usr/share/doc/ghc/html/libraries"
+ ln -s /usr/share/doc/${pkgname}/html "${pkgdir}/usr/share/doc/ghc/html/libraries/${_hkgname}"
+ runhaskell Setup copy --destdir="${pkgdir}"
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ rm -f "${pkgdir}/usr/share/doc/${pkgname}/LICENSE"
+}
+
diff --git a/haskell-alsa-mixer.install b/haskell-alsa-mixer.install
new file mode 100644
index 000000000000..3392eccbd3c3
--- /dev/null
+++ b/haskell-alsa-mixer.install
@@ -0,0 +1,27 @@
+# custom variables
+pkgname=haskell-alsa-mixer
+HS_DIR=/usr/share/haskell/${pkgname}
+
+# functions
+post_install() {
+ ${HS_DIR}/register.sh
+ (cd /usr/share/doc/ghc/html/libraries; ./gen_contents_index)
+}
+
+pre_upgrade() {
+ ${HS_DIR}/unregister.sh
+}
+
+post_upgrade() {
+ ${HS_DIR}/register.sh
+ (cd /usr/share/doc/ghc/html/libraries; ./gen_contents_index)
+}
+
+pre_remove() {
+ ${HS_DIR}/unregister.sh
+}
+
+post_remove() {
+ (cd /usr/share/doc/ghc/html/libraries; ./gen_contents_index)
+}
+