summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDamien Flament2016-11-14 14:53:11 +0100
committerDamien Flament2016-11-14 14:53:11 +0100
commit9e6cee3477cb8caa47f677aba9a0ab86c5e9a1a8 (patch)
tree3edd6819e48a338b2626ba694a234b316aa03cd0
parentf7644cc69a438ef5f0e32da7cad88548037c6039 (diff)
downloadaur-9e6cee3477cb8caa47f677aba9a0ab86c5e9a1a8.tar.gz
[PATCH] Adapt to Cabal-1.22.
-rw-r--r--Adapt_to_Cabal_1-22.patch37
-rw-r--r--PKGBUILD7
2 files changed, 42 insertions, 2 deletions
diff --git a/Adapt_to_Cabal_1-22.patch b/Adapt_to_Cabal_1-22.patch
new file mode 100644
index 000000000000..085169566946
--- /dev/null
+++ b/Adapt_to_Cabal_1-22.patch
@@ -0,0 +1,37 @@
+From 7e29ed8264cc46cbdce1c90c9784b33373714c34 Mon Sep 17 00:00:00 2001
+From: Nikolay Orlyuk <virkony@gmail.com>
+Date: Sun, 31 May 2015 20:09:18 +0300
+Subject: [PATCH] adapt to Cabal-1.22
+
+---
+ Distribution/ArchLinux/CabalTranslation.hs | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/Distribution/ArchLinux/CabalTranslation.hs b/Distribution/ArchLinux/CabalTranslation.hs
+index 7669e97..a3f278c 100644
+--- a/Distribution/ArchLinux/CabalTranslation.hs
++++ b/Distribution/ArchLinux/CabalTranslation.hs
+@@ -43,7 +43,7 @@ preprocessCabal cabalsrc systemContext =
+ []
+ (const True) -- could check against prefered pkgs....
+ (Platform X86_64 buildOS) -- linux/x86_64
+- (CompilerId GHC (Version [7,0,3] []))
++ (CompilerInfo (CompilerId GHC (Version [7,0,3] [])) NoAbiTag Nothing Nothing Nothing)
+
+ -- now constrain it to solve in the context of a modern ghc only
+ (corePackages systemContext ++ platformPackages systemContext)
+@@ -117,9 +117,9 @@ cabal2pkg' cabal archName release systemContext
+ x@LGPL {} -> x
+ l -> UnknownLicense ("custom:"++ show l)
+ , arch_package = (arch_package stub) ++
+- (if not (null (licenseFile cabal)) && (case license cabal of GPL {} -> False; LGPL {} -> False; _ -> True)
++ (if not (null (licenseFiles cabal)) && (case license cabal of GPL {} -> False; LGPL {} -> False; _ -> True)
+ then
+- [ "install -D -m644 " ++ licenseFile cabal ++ " ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
++ [ "install -D -m644 " ++ unwords (licenseFiles cabal) ++ " ${pkgdir}/usr/share/licenses/${pkgname}/"
+ , "rm -f ${pkgdir}/usr/share/doc/${pkgname}/LICENSE"
+ ]
+ else []) }
+--
+2.10.2
+
diff --git a/PKGBUILD b/PKGBUILD
index 83f688396f71..7eb1dab08f9d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,7 +18,8 @@ options=('strip' 'staticlibs')
source=("http://hackage.haskell.org/packages/${_hkgname}-${pkgver}/${_hkgname}-${pkgver}.tar.gz"
"Hide_Data-Monoid_function.patch"
"Add_FlexibleInstances.patch"
- "Adapt_to_Applicative-Monad.patch")
+ "Adapt_to_Applicative-Monad.patch"
+ "Adapt_to_Cabal_1-22.patch")
install="${pkgname}.install"
prepare() {
@@ -27,6 +28,7 @@ prepare() {
patch -Np1 -i "${srcdir}/Hide_Data-Monoid_function.patch"
patch -Np1 -i "${srcdir}/Add_FlexibleInstances.patch"
patch -Np1 -i "${srcdir}/Adapt_to_Applicative-Monad.patch"
+ patch -Np1 -i "${srcdir}/Adapt_to_Cabal_1-22.patch"
}
build() {
@@ -55,4 +57,5 @@ package() {
md5sums=('13b2e9336b31b3f7a3e5410308023ae5'
'db16c7d948f0aed4909ae6a0bf7180a8'
'6a9bed2c0bb13fbc925a40c4571a7330'
- '444868f76ba946afc96676eb47be1b81')
+ '444868f76ba946afc96676eb47be1b81'
+ '228927282cee988a52255ef58e7e2f32')