summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDāvis Mosāns2022-08-16 05:06:00 +0300
committerDāvis Mosāns2022-08-16 05:06:00 +0300
commitd21d7ca3763459a310d6e7565ebf66bd49c35f7f (patch)
tree08033a7bf3a0e4b92eac56989194d42e280662cd
downloadaur-d21d7ca3763459a310d6e7565ebf66bd49c35f7f.tar.gz
First release
-rw-r--r--.SRCINFO22
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD45
-rw-r--r--Setup.hs4
4 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..894ab02a543e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = haskell-autodocodec
+ pkgdesc = Self-documenting encoder and decoder
+ pkgver = 0.2.0.0
+ pkgrel = 1
+ url = https://github.com/NorfairKing/autodocodec#readme
+ arch = x86_64
+ license = MIT
+ makedepends = ghc
+ depends = ghc-libs
+ depends = haskell-aeson
+ depends = haskell-hashable
+ depends = haskell-scientific
+ depends = haskell-unordered-containers
+ depends = haskell-validity
+ depends = haskell-validity-scientific
+ depends = haskell-vector
+ source = https://hackage.haskell.org/packages/archive/autodocodec/0.2.0.0/autodocodec-0.2.0.0.tar.gz
+ source = Setup.hs
+ sha256sums = af3abe177924979cfe7ca734a4ddc27966ca563974e50450f577e191c145b637
+ sha256sums = f2a37c4a254ff8eb780133ca568ae5f4f4dcdee5219982154e6faef749b8327c
+
+pkgname = haskell-autodocodec
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..8ba3a617d3d9
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg/
+/src/
+/*.tar*
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7b4966b21676
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# This file was generated by https://github.com/berberman/arch-hs, please check it manually.
+
+_hkgname=autodocodec
+pkgname=haskell-autodocodec
+pkgver=0.2.0.0
+pkgrel=1
+pkgdesc="Self-documenting encoder and decoder"
+url="https://github.com/NorfairKing/autodocodec#readme"
+license=("MIT")
+arch=('x86_64')
+depends=('ghc-libs' 'haskell-aeson' 'haskell-hashable' 'haskell-scientific' 'haskell-unordered-containers' 'haskell-validity' 'haskell-validity-scientific' 'haskell-vector')
+makedepends=('ghc')
+source=("https://hackage.haskell.org/packages/archive/$_hkgname/$pkgver/$_hkgname-$pkgver.tar.gz" 'Setup.hs')
+sha256sums=('af3abe177924979cfe7ca734a4ddc27966ca563974e50450f577e191c145b637'
+ 'f2a37c4a254ff8eb780133ca568ae5f4f4dcdee5219982154e6faef749b8327c')
+
+prepare() {
+ cp Setup.hs "$_hkgname-$pkgver/"
+}
+
+build() {
+ cd $_hkgname-$pkgver
+
+ runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
+ --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=haskell-autodocodec --enable-tests \
+ --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid \
+ --ghc-option=-optl-Wl\,-z\,relro\,-z\,now \
+ --ghc-option='-pie'
+
+ runhaskell Setup build
+ runhaskell Setup register --gen-script
+ runhaskell Setup unregister --gen-script
+ sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
+ sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
+}
+
+package() {
+ cd $_hkgname-$pkgver
+
+ install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
+ install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
+ runhaskell Setup copy --destdir="$pkgdir"
+ install -D -m644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/
+ rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE
+}
diff --git a/Setup.hs b/Setup.hs
new file mode 100644
index 000000000000..6479cb1c1645
--- /dev/null
+++ b/Setup.hs
@@ -0,0 +1,4 @@
+import Distribution.Simple
+
+main = defaultMain
+