summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author71e6fd522020-02-29 13:22:29 +0800
committer71e6fd522020-02-29 13:22:29 +0800
commitaca0f3b9c39ab88b68a6e6d5b7b7b25ec699c0a4 (patch)
treed264fec4bcd41cd7a67d3c2cbaf91e1a99c09a98
downloadaur-aca0f3b9c39ab88b68a6e6d5b7b7b25ec699c0a4.tar.gz
1.3.2.3
-rw-r--r--.SRCINFO28
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD48
3 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b7bcd944fea2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = haskell-butcher
+ pkgdesc = Chops a command or program invocation into digestable pieces.
+ pkgver = 1.3.2.3
+ pkgrel = 1
+ url = https://hackage.haskell.org/package/butcher
+ arch = x86_64
+ license = BSD3
+ makedepends = ghc
+ depends = ghc-libs
+ depends = haskell-bifunctors
+ depends = haskell-containers
+ depends = haskell-deque
+ depends = haskell-extra
+ depends = haskell-free
+ depends = haskell-hspec
+ depends = haskell-microlens
+ depends = haskell-microlens-th
+ depends = haskell-mtl
+ depends = haskell-multistate
+ depends = haskell-pretty
+ depends = haskell-transformers
+ depends = haskell-unsafe
+ depends = haskell-void
+ source = https://hackage.haskell.org/packages/archive/butcher/1.3.2.3/butcher-1.3.2.3.tar.gz
+ sha512sums = 55e2fc0ee8d35ddd90a7e6bbf65355423f7d71a3e1097f0a93706361f10796773b717d5e2e17c700fa7f7c7fa6fdef9aaa0f103af755fa06523b684f162018d4
+
+pkgname = haskell-butcher
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..8e8409730516
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+*
+!.*
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3bbd00d05bb0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: 71e6fd52 <71e6fd52 at gmail dot com>
+
+_hkgname=butcher
+pkgname=haskell-butcher
+pkgver=1.3.2.3
+pkgrel=1
+pkgdesc='Chops a command or program invocation into digestable pieces.'
+url='https://hackage.haskell.org/package/butcher'
+license=('BSD')
+arch=('x86_64')
+depends=('ghc-libs' 'haskell-bifunctors' 'haskell-containers' 'haskell-deque' 'haskell-extra' 'haskell-free' 'haskell-hspec' 'haskell-microlens' 'haskell-microlens-th' 'haskell-mtl' 'haskell-multistate' 'haskell-pretty' 'haskell-transformers' 'haskell-unsafe' 'haskell-void')
+makedepends=('ghc')
+source=("https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
+sha512sums=('55e2fc0ee8d35ddd90a7e6bbf65355423f7d71a3e1097f0a93706361f10796773b717d5e2e17c700fa7f7c7fa6fdef9aaa0f103af755fa06523b684f162018d4')
+
+prepare() {
+ cd $_hkgname-$pkgver
+
+ sed -i 's/base .*$/base/' butcher.cabal
+}
+
+build() {
+ cd $_hkgname-$pkgver
+
+ runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
+ --prefix=/usr --docdir=/usr/share/doc/$pkgname --enable-tests \
+ --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid
+ runhaskell Setup build
+ runhaskell Setup register --gen-script
+ runhaskell Setup unregister --gen-script
+ sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
+ sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
+}
+
+check() {
+ cd $_hkgname-$pkgver
+ runhaskell Setup test
+}
+
+package() {
+ cd $_hkgname-$pkgver
+
+ install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
+ install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
+ runhaskell Setup copy --destdir="$pkgdir"
+ install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+ rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE
+}