summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndré van Delden2015-06-29 16:35:56 +0200
committerAndré van Delden2015-06-29 16:35:56 +0200
commit226ca2148aa4aa703d1ac489014b406718939af9 (patch)
treea4133753c5039306d5e36c3f9fda8c069630ba54
downloadaur-226ca2148aa4aa703d1ac489014b406718939af9.tar.gz
Initial import
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD40
-rw-r--r--haskell-bytes.install18
3 files changed, 83 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..713b78ea1fe9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = haskell-bytes
+ pkgdesc = Sharing code for serialization between binary and cereal
+ pkgver = 0.15
+ pkgrel = 1
+ url = http://hackage.haskell.org/package/bytes
+ install = haskell-bytes.install
+ arch = any
+ license = BSD3
+ depends = ghc
+ depends = haskell-cereal>=0.4.1.1
+ depends = haskell-cereal<0.5
+ depends = haskell-mtl>=2.0
+ depends = haskell-mtl<2.3
+ depends = haskell-text>=0.2
+ depends = haskell-text<1.3
+ depends = haskell-transformers-compat>=0.3
+ depends = haskell-transformers-compat<1
+ depends = haskell-void>=0.6
+ depends = haskell-void<1
+ options = strip
+ source = http://hackage.haskell.org/packages/archive/bytes/0.15/bytes-0.15.tar.gz
+ sha512sums = 8f53855392a2a682d1a28b6ba42b7d701303a150832a5e51c2ed541b2fb8ec3555f47201e717a1a9d781b176a0608e802e67207e77a4125a84ae0338f0148d0d
+
+pkgname = haskell-bytes
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..861c9f889480
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: André van Delden <andre.van.delden@uni-bremen.de>
+
+_hkgname=bytes
+pkgname=haskell-bytes
+pkgver=0.15
+pkgrel=1
+pkgdesc="Sharing code for serialization between binary and cereal "
+url="http://hackage.haskell.org/package/${_hkgname}"
+license=('BSD3')
+arch=('any')
+makedepends=()
+depends=('ghc' 'haskell-cereal>=0.4.1.1' 'haskell-cereal<0.5'
+ 'haskell-mtl>=2.0' 'haskell-mtl<2.3'
+ 'haskell-text>=0.2' 'haskell-text<1.3'
+ 'haskell-transformers-compat>=0.3' 'haskell-transformers-compat<1'
+ 'haskell-void>=0.6' 'haskell-void<1')
+options=('strip')
+source=(http://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz)
+install=${pkgname}.install
+sha512sums=('8f53855392a2a682d1a28b6ba42b7d701303a150832a5e51c2ed541b2fb8ec3555f47201e717a1a9d781b176a0608e802e67207e77a4125a84ae0338f0148d0d')
+build() {
+ cd ${srcdir}/${_hkgname}-${pkgver}
+ runhaskell Setup configure -O ${PKGBUILD_HASKELL_ENABLE_PROFILING:+-p } --enable-split-objs --enable-shared \
+ --prefix=/usr --docdir=/usr/share/doc/${pkgname} --libsubdir=\$compiler/site-local/\$pkgid
+ runhaskell Setup build
+ runhaskell Setup haddock
+ runhaskell Setup register --gen-script
+ runhaskell Setup unregister --gen-script
+ sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
+}
+package() {
+ cd ${srcdir}/${_hkgname}-${pkgver}
+ install -D -m744 register.sh ${pkgdir}/usr/share/haskell/${pkgname}/register.sh
+ install -m744 unregister.sh ${pkgdir}/usr/share/haskell/${pkgname}/unregister.sh
+ install -d -m755 ${pkgdir}/usr/share/doc/ghc/html/libraries
+ ln -s /usr/share/doc/${pkgname}/html ${pkgdir}/usr/share/doc/ghc/html/libraries/${_hkgname}
+ runhaskell Setup copy --destdir=${pkgdir}
+ install -D -m644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+ rm -f ${pkgdir}/usr/share/doc/${pkgname}/LICENSE
+}
diff --git a/haskell-bytes.install b/haskell-bytes.install
new file mode 100644
index 000000000000..7e5dfcdc0b92
--- /dev/null
+++ b/haskell-bytes.install
@@ -0,0 +1,18 @@
+HS_DIR=usr/share/haskell/haskell-bytes
+post_install() {
+ ${HS_DIR}/register.sh
+ (cd usr/share/doc/ghc/html/libraries; ./gen_contents_index)
+}
+pre_upgrade() {
+ ${HS_DIR}/unregister.sh
+}
+post_upgrade() {
+ ${HS_DIR}/register.sh
+ (cd usr/share/doc/ghc/html/libraries; ./gen_contents_index)
+}
+pre_remove() {
+ ${HS_DIR}/unregister.sh
+}
+post_remove() {
+ (cd usr/share/doc/ghc/html/libraries; ./gen_contents_index)
+}