summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhoffer.joshua2019-06-01 19:58:36 -0600
committerhoffer.joshua2019-06-01 19:58:36 -0600
commit9bada538d15f38c2f8d4eb84fcbdcfd1b701192d (patch)
tree504326a44bef8905fac67e7e0c9db0476e2c757d
downloadaur-9bada538d15f38c2f8d4eb84fcbdcfd1b701192d.tar.gz
initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD43
2 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fd2276e855d4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = haskell-bytestring-progress
+ pkgver = 1.2
+ pkgrel = 2
+ url = http://hackage.haskell.org/package/bytestring-progress
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = ghc
+ makedepends = haskell-base<5
+ makedepends = haskell-base>=4.0
+ makedepends = haskell-bytestring
+ makedepends = haskell-time>=1.1
+ makedepends = haskell-time<2.0
+ makedepends = haskell-terminal-progress-bar>=0.2.0
+ depends = ghc
+ options = strip
+ source = https://hackage.haskell.org/packages/archive/bytestring-progress/1.2/bytestring-progress-1.2.tar.gz
+ md5sums = 502e643aa440f04d5efe02577aec6f33
+
+pkgname = haskell-bytestring-progress
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e5b1e1cbb506
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Josh Hoffer
+_hkgname=bytestring-progress
+pkgname=haskell-bytestring-progress
+pkgver=1.2
+pkgrel=2
+pkgdesk="A library for tracking the consumption of a lazy ByteString"
+url="http://hackage.haskell.org/package/bytestring-progress"
+license=('BSD')
+arch=('i686' 'x86_64')
+depends=('ghc')
+makedepends=('ghc'
+ 'haskell-base<5'
+ 'haskell-base>=4.0'
+ 'haskell-bytestring'
+ 'haskell-time>=1.1'
+ 'haskell-time<2.0'
+ 'haskell-terminal-progress-bar>=0.2.0'
+)
+#'haskell-terminal-progress-bar<0.3.0' # seems to work fine with latest version
+options=('strip')
+source=(https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz)
+
+build() {
+ cd ${srcdir}/${_hkgname}-${pkgver}
+ runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
+ --prefix=/usr --docdir=/usr/share/doc/$pkgname \
+ --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid
+
+ runhaskell Setup build
+ runhaskell Setup register --gen-script
+ runhaskell Setup unregister --gen-script
+ sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
+ sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
+}
+
+package() {
+ cd ${srcdir}/${_hkgname}-${pkgver}
+ install -Dm 744 register.sh "${pkgdir}/usr/share/haskell/register/${pkgname}.sh"
+ install -Dm 744 unregister.sh "${pkgdir}/usr/share/haskell/unregister/${pkgname}.sh"
+ runhaskell Setup copy --destdir="${pkgdir}"
+ install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/bytestring-progress"
+}
+md5sums=('502e643aa440f04d5efe02577aec6f33')