summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLoen2016-07-09 10:35:25 +0000
committerLoen2016-07-09 10:35:25 +0000
commit8886e9f4921af288980f38ed602ae9fee95d4a49 (patch)
tree3812ef68b166dc2f2e9c4819a01c42b48890480f
downloadaur-8886e9f4921af288980f38ed602ae9fee95d4a49.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD33
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9dcc6040c16a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = haskell-curl
+ pkgdesc = Haskell binding to libcurl
+ pkgver = 1.3.8
+ pkgrel = 1
+ url = None
+ arch = any
+ license = BSD3
+ depends = ghc
+ depends = haskell-base
+ depends = haskell-bytestring
+ depends = haskell-containers
+ options = strip
+ source = https://hackage.haskell.org/package/curl-1.3.8/curl-1.3.8.tar.gz
+ sha256sums = 9087c936bfcdb865bad3166baa3f12bf37acf076fa76010e3b5f82a1d485446e
+
+pkgname = haskell-curl
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3b2351b52f17
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Christopher Loen <christopherloen at gmail dot com>
+# Generated by hkg2arch --> https://github.com/christopherloen/hkg2arch
+hkgname=curl
+pkgname=haskell-curl
+pkgrel=1
+pkgver=1.3.8
+pkgdesc='Haskell binding to libcurl'
+arch=(any)
+url='None'
+license=(BSD3)
+depends=(ghc haskell-base haskell-bytestring haskell-containers)
+options=(strip)
+source=(https://hackage.haskell.org/package/curl-1.3.8/curl-1.3.8.tar.gz)
+sha256sums=(9087c936bfcdb865bad3166baa3f12bf37acf076fa76010e3b5f82a1d485446e)
+build(){
+ cd ${srcdir}/${hkgname}-${pkgver}
+ runhaskell Setup configure -O ${PKGBUILD_HASKELL_ENABLE_PROFILING:+-p } --enable-split-objs --enable-shared --prefix=/usr --docdir=/usr/share/doc/${pkgname} --libsubdir='$compiler'/site-local/'$pkgid'
+ runhaskell Setup build
+ runhaskell Setup haddock
+ runhaskell Setup register --gen-script
+ runhaskell Setup unregister --gen-script
+ sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
+ }
+package() {
+ cd ${srcdir}/${hkgname}-${pkgver}
+ install -D -m744 register.sh ${pkgdir}/usr/share/haskell/${pkgname}/register.sh
+ install -m744 unregister.sh ${pkgdir}/usr/share/haskell/${pkgname}/unregister.sh
+ install -d -m755 ${pkgdir}/usr/share/doc/ghc/html/libraries
+ ln -s /usr/share/doc/${pkgname}/html ${pkgdir}/usr/share/doc/ghc/html/libraries/${hkgname}
+ runhaskell Setup copy --destdir=${pkgdir}
+ install -D -m644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+ rm -f ${pkgdir}/usr/share/doc/${pkgname}/LICENSE
+}