summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Nagy2015-06-08 20:28:52 +0200
committerDaniel Nagy2015-06-08 20:28:52 +0200
commit12bf12816d7a49696e9df829be77d2b3a0c3e1ac (patch)
treea0f92ae99cb22c68e463041dfe9e360e357abfd5
downloadaur-12bf12816d7a49696e9df829be77d2b3a0c3e1ac.tar.gz
import to aur4
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD49
-rw-r--r--haskell-data-accessor.install26
3 files changed, 95 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fc25cfb6d289
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = haskell-data-accessor
+ pkgdesc = Utilities for accessing and manipulating fields of records
+ pkgver = 0.2.2.6
+ pkgrel = 1
+ url = http://www.haskell.org/haskellwiki/Record_access
+ install = haskell-data-accessor.install
+ arch = i686
+ arch = x86_64
+ license = BSD3
+ depends = ghc
+ depends = sh
+ depends = haskell-array
+ depends = haskell-containers
+ depends = haskell-transformers
+ options = strip
+ source = http://hackage.haskell.org/packages/archive/data-accessor/0.2.2.6/data-accessor-0.2.2.6.tar.gz
+ sha256sums = ee9de7fd9716f2681695deffcd04045d605bd24f0f2c7d6f0849dc4ae9c3c818
+
+pkgname = haskell-data-accessor
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c5450f81f421
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Daniel Nagy <danielnagy at gmx de>
+
+# custom variables
+_hkgname=data-accessor
+_licensefile=LICENSE
+
+# PKGBUILD options/directives
+pkgname=haskell-data-accessor
+pkgver=0.2.2.6
+pkgrel=1
+pkgdesc="Utilities for accessing and manipulating fields of records"
+url="http://www.haskell.org/haskellwiki/Record_access"
+license=("BSD3")
+arch=('i686' 'x86_64')
+makedepends=()
+depends=("ghc"
+ "sh"
+ "haskell-array"
+ "haskell-containers"
+ "haskell-transformers")
+options=('strip')
+source=("http://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
+sha256sums=('ee9de7fd9716f2681695deffcd04045d605bd24f0f2c7d6f0849dc4ae9c3c818')
+install="${pkgname}.install"
+
+# PKGBUILD functions
+build() {
+ cd ${srcdir}/${_hkgname}-${pkgver}
+
+ runhaskell Setup configure -O -p --enable-split-objs --enable-shared \
+ --prefix=/usr --docdir=/usr/share/doc/${pkgname} \
+ --libsubdir=\$compiler/site-local/\$pkgid
+ runhaskell Setup build
+ runhaskell Setup haddock
+ runhaskell Setup register --gen-script
+ runhaskell Setup unregister --gen-script
+ sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
+}
+
+package() {
+ cd ${srcdir}/${_hkgname}-${pkgver}
+ install -D -m744 register.sh ${pkgdir}/usr/share/haskell/${pkgname}/register.sh
+ install -m744 unregister.sh ${pkgdir}/usr/share/haskell/${pkgname}/unregister.sh
+ install -d -m755 ${pkgdir}/usr/share/doc/ghc/html/libraries
+ ln -s /usr/share/doc/${pkgname}/html ${pkgdir}/usr/share/doc/ghc/html/libraries/${_hkgname}
+ runhaskell Setup copy --destdir=${pkgdir}
+ install -D -m644 ${_licensefile} ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+ rm -f ${pkgdir}/usr/share/doc/${pkgname}/${_licensefile}
+}
diff --git a/haskell-data-accessor.install b/haskell-data-accessor.install
new file mode 100644
index 000000000000..1f17f8ee348f
--- /dev/null
+++ b/haskell-data-accessor.install
@@ -0,0 +1,26 @@
+# custom variables
+pkgname=haskell-data-accessor
+HS_DIR=usr/share/haskell/${pkgname}
+
+# functions
+post_install() {
+ ${HS_DIR}/register.sh
+ (cd usr/share/doc/ghc/html/libraries; ./gen_contents_index)
+}
+
+pre_upgrade() {
+ ${HS_DIR}/unregister.sh
+}
+
+post_upgrade() {
+ ${HS_DIR}/register.sh
+ (cd usr/share/doc/ghc/html/libraries; ./gen_contents_index)
+}
+
+pre_remove() {
+ ${HS_DIR}/unregister.sh
+}
+
+post_remove() {
+ (cd usr/share/doc/ghc/html/libraries; ./gen_contents_index)
+}